Jump to content

(PNG) save problem


Recommended Posts

PDN 3.5.8 (64bit) on Windows 7.

Sometimes when I'm saving an image as png the content is not correct. It looks like that the save funtion does not get the correct data from memory. It is not deterministic, so I can't provide a step by step instruction to reproduce the problem. I'm guessing I did always the following:

- create a new image

- copy something in

- save the image (which asks for a name)

- selecting a name with extension .png

- the png option dialog appears

- maybe I pressed OK before the preview has been computed

- the funtion terminates w/o error but the content is not correct

I'm not sure if this a png problem or a general problem with the save function.

A second save gives the correct content.

It happened 4 or 5 times for me in 4 weeks. So not quite often but because you are not getting an error message it is a risky thing...

Incorrect content:

Fassaden%20SN%20destroyed.png

Correct content:

Fassaden%20SN%20small.png

midoras signature.gif

Link to comment
Share on other sites

  • 2 weeks later...

If you can get me a consistent, or even semi-consistent, list of repro steps and a sample image, that will help.

What type of system do you have? As in, OS, CPU (make & model), RAM.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...