Jump to content

Install prob's w/ PDN and .NET framework


Recommended Posts

The Problem: Recently due to unforeseen technical difficulties in my C:// which were completely not my fault, I was lead little choice but to use system restore. I've done this before, and PDN came back up with little effort; however this time:

error.jpg

I tried DLing .NET framework several times. 3 different versions, 2 times each. Alas, I feel I wasted time, same error with each. These were the links I DL'd in order, which I remember because the links are purple on google:

.NET 3.5

.NET 4.0 (newest)

.NET 2.0 (did I? can't remember, but link's purple).

.NET 3.0 (on faqs)

Most of them claimed to had install, with the above error; 3.0 however claimed to have failed with this:

net.jpg

Again, I tried each twice with several restarts in between, and I get the same "X" error message above when opening PDN 3.5.8 (I also tried reinstalling and uninstalling PDN 3.5.8 several times, no success). It may be worth mentioning that the day after system restore, Windows auto-updates itself (turned on)... but in the middle of it, I had to shut down the computer early. Also, unlike my first system restore, this one occured because I was, erm, tampering unwittingly in the C://, although any problems there should have been cured with system restore, right? Thanks so much if you talented people can get to the bottom of this. :)

Link to comment
Share on other sites

prog.jpg

Although I distinctly remember DLing all in the list above multiple times, only 1.1, 4 Client Profile, and 4 Extended actually appear on the repair. I successfully repaired Framework 4 Client Profile first, and both before and after a restart, I got the same PDN error message. I recently successfully repaired Framework 4 Extended, and without a restart, I got the same error message. Then I tried repairing Framework 1.1; however, the option didn't show up. Rather, it immediately asked me whether I would like to remove it.

:( Thanks Pyro, but do you or anyone else have any other ideas on what I can do? I quite miss PDN.

Link to comment
Share on other sites

I seem to recall reading somewhere that the .NET versions need to be installed in order.

If I'm right, you may need to uninstall 4.0 before reinstalling 2.0, 3.0 & 3.5 then reinstalling 4.0. DON'T DO THIS YET. Await confirmation as I don't seem to be able to find the reference post/article I'm looking for.

Edit: this page from Microsoft tells me I'm wrong http://msdn.microsoft.com/en-us/library/bb822049.aspx

Link to comment
Share on other sites

So you got .NET 4 repaired successfully? In that case, you can force Paint.NET to use .NET 4 by going to the folder in which Paint.NET is installed (usually C:\Program Files\Paint.NET) and opening the file PaintDotNet.exe.config in a text editor like Notepad.

Switch these 2 lines:

<supportedRuntime version="v2.0.50727" sku="Client"/>

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0,Profile=Client"/>

so that it's:

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0,Profile=Client"/>

<supportedRuntime version="v2.0.50727" sku="Client"/>

Save the file, and try to start Paint.NET.

xZYt6wl.png

ambigram signature by Kemaru

[i write plugins and stuff]

If you like a post, upvote it!

Link to comment
Share on other sites

I tried your solution above, Pyro, and got this:

further.jpg

Before trying this solution, I tried re-DLing 3.5 SP1 through a different website (although it had the same exact file name & size). Got this error:

prob.jpg

Now that I think about it, this looks kinda familiar. Although I know for sure Framework 4 was DL'd successfully, it's possible that I had gotten this before with 3.5 (and I got confused because I was DLing things over and over so much I lost track?)

Thanks so much for your current solutions, Pyro and EER. :( What else can I try?

Link to comment
Share on other sites

This time, when I tried it, I got the same repair window. But this time when I clicked repair, the black window instantly came up and closed within 1 second, without the "requires 3.5 SP1 or greater" window. I then went to every individual file in the pdn folder with a notepad icon and did the same thing, with no difference.

file.jpg

In the above image of my pdn folder, could I be missing something (or having something unnecessary in there) which could be the problem?

Link to comment
Share on other sites

wic.jpg

After downloading Windows Installer Clean-up, Paint.Net didn't appear on the list. It didn't show up on the lists for Control Panel's Remove Programs nor Revo Uninstaller either. Even though everything on my computer got wiped out, I clearly remember finishing the installation for PDN several (2 or 3) times.

Masked Burito, I've tried dl'ing SP 2 and 3 twice or more each, in which it would say it was successfully installed. And although SP 2 & 3 don't appear on either of my lists, is there anything SP 2 or 3 could do which Framework 4 can't do? Is it possible that the installation of Framework 4 interferes with SP 2 or 3 appearing, and that's the root to my problem? :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...