null54

PSFilterPdn (2019-01-04)

Recommended Posts

SHE LIVES !!!  I finally got it working.  For some reason when I extracted the dll and shim from 1.0.5.5 and opted to replace all files, it didn't.  I had a folder in effects labelled PSFilterPdn but I was denied access to open it to get the dll and shim out.  I moved that folder to the desktop to get it out of the way and then extracted the files from the zip again and IT WORKS !!!

 

Thanks ever so much for your time and attention to this issue.  You're the best!

  • Upvote 1

Share this post


Link to post
Share on other sites

Added support for loading shortcuts to folders.
Fixed a crash with the filter edge padding.

 

File version updated to 1.0.5.7.

Share this post


Link to post
Share on other sites

Added support for displaying the UI of the last used filter with the parameters from the previous session.

Improved performance when loading filters on a 32-bit OS.

 

File version updated to 1.0.5.8.

  • Upvote 1

Share this post


Link to post
Share on other sites

Just started testing PSFilterPdn with several Topaz Labs plug-ins, all 64-bit versions, and they all seem to be working just fine.  The filters are Adjust, Clarity, Detail, DeNoise, InFocus and ReMask.  .The last 3 in particular will be most useful to me.  (FWIW, I just upgraded to v.1.0.5.8 today, the plug-ins were working with a previous version, unknown number; decided to check for update just in case.)

 

My forum search didn't find any other reference to the use of Topaz in PdN, so I thought I'd share my experience.

 

At this point, however, consider this just a very strong opinion and not gospel.  And kudos to null54, and a big thanks.  Now to go test lots of other 8bf filters!

 

--GeorgeB (aka JustGeorge39)

Share this post


Link to post
Share on other sites

Added support for displaying transparency as a floating selection.
Improved the performance when searching for filters.

 

File version updated to 1.0.5.9.

  • Upvote 2

Share this post


Link to post
Share on other sites

For those who have downloaded Photoshop plugins/filters from Filters Factory and/or Two Moon ( also those from somewhere else )...

 

Any of you experiencing this kind of experience ? I mean a prompt box with a message popped out when you ran the plugin/filters. Telling something like this :

 

 " The specified module could not be found ( Exception from HResults :0X8007007E)" 

 

And your plugins/filters can't work or you have to shut down Paint.Net.

 

If you are, here are the steps of solution which I got from Null54 himself :

 

1. Download MSVCRT10.dll from The Plugin Site

2. Put that file on Paint.NET Effects folder.

3. Re-run PSFilterPDN again and re-run the specified plugins/filters. In my case, my Paint.NET requires no restarting.

 

The specified dll file needed is a mandatory for running all filters by Filters Factory.

 

This solved my problem as I have just now gotten around to gathering 8bf filters, organizing, and now using this amazing plugin.

 

THANK YOU SO MUCH FOR MAKING THIS!! absolutely wonderful. Very, VERY appreciative.

 

I have a request. Can you add an "undo" feature to the plugin UI because once the special effect is chosen and implemented, well, there are several more to see how they will look on the image, too. While the plugin is being used, the PDN "undo" cannot be used. So, after experimenting with one effect the whole plugin must be closed, click undo within PDN, go back to "Effects", scroll down to the bottom, click on the plugin, sort through to find the other effect and then repeating all steps to see how another plugin will  look. As it is, the plugin does stay up to add another effect, but not undo the prior effect.

 

I ABSOLUTELY LOVE!!! This plugin!

Edited by ScrapbookWithPDN

Share this post


Link to post
Share on other sites

I have a request. Can you add an "undo" feature to the plugin UI because once the special effect is chosen and implemented, well, there are several more to see how they will look on the image, too. While the plugin is being used, the PDN "undo" cannot be used. So, after experimenting with one effect the whole plugin must be closed, click undo within PDN, go back to "Effects", scroll down to the bottom, click on the plugin, sort through to find the other effect and then repeating all steps to see how another plugin will  look. As it is, the plugin does stay up to add another effect, but not undo the prior effect.

 

PSFilterPdn will only apply the effect to the original image when the OK button is pressed, so you can try out multiple filters and it will only keep the most recent one.

Share this post


Link to post
Share on other sites

Fixed an alpha channel bug with the Dfine 2 filter from the Google Nik Collection.
Fixed a bug with the Vizros 4 Lake filter.
Various other performance improvements.

 

File version updated to 1.0.6.0.

  • Upvote 1

Share this post


Link to post
Share on other sites

You mentioned on my thread that this is compatible with Google Color Nik.

 

It asks me during the installation to browse for a host program. I'm not sure what to do with that. Can I just install Google Color Nik without a host program and just browse to its installation directory using PSFilterPdn?

 

 

 

Share this post


Link to post
Share on other sites

It asks me during the installation to browse for a host program. I'm not sure what to do with that. Can I just install Google Color Nik without a host program and just browse to its installation directory using PSFilterPdn?

 

Yes, see Searching other folders.

  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for this Null54! :beer:
I installed the Google Nik plugins and the PSFilter last night (pointed Nik to Pdn 4.0.9 and installed in Effects) - all works perfectly! B)

Share this post


Link to post
Share on other sites

I managed to install Google Color Nik now and its working with PSFilterPdn.

 

I'm using the latest version of PSFilterPdn and also the latest version of Google Color Nik which is now free to download and use. I am running Windows 8.1 Pro 32 bit with Paint.NET v.4.09.

 

Its an awesome awesome plugin pack by the way but some of its programs would have these rectangular black patches of space on the user interface itself that shrink, disappear and re-appear on random on the window of the program as I scroll. I'm still able to use the program's functions but these rectangular black patches bugs are interfering with my work on the Google Color Nik programs.

 

I dunno if its a bug with Google Color Nik itself or perhaps in the way PSFilterPdn hosts them. I also observed that Google Color Nik is a bit slow in loading the images even if they are only moderately sized.

 

Here's a screenshot of the bug. As you can see, it engulfs 40% of the window of Analog Efex Pro.

 

e1685a0fed37.png

Share this post


Link to post
Share on other sites

That issue does not appear for me.

 

The Nik plugins launch a separate program to process the image, so that may be a rendering bug with its custom UI.

It could also be a graphics driver issue, the OS being low on resources or any number of other things.

  • Upvote 1

Share this post


Link to post
Share on other sites

That issue does not appear for me.

 

The Nik plugins launch a separate program to process the image, so that may be a rendering bug with its custom UI.

It could also be a graphics driver issue, the OS being low on resources or any number of other things.

 

Me too... It works perfectly on my Paint.NET 4.0.9 at Windows partition. My lappy GPU is ATI Radeon HD4200, so that's a factor. How about yours ? I believe Nvidia users also get benefits from Google Nik Plugins.

 

BTW, I have problems to run PSFilterShim.exe while using PSFilter plugins on Paint.NET 3.5.11 at my Linux partition. I can't understand why. Each time I tried to run the plugin, I bumped to the same message from Wine.

 

 

post-136545-0-09217700-1467741390_thumb.

 

 

Any ideas and how to solve it ?

Share this post


Link to post
Share on other sites

Any ideas and how to solve it ?

 

That error is caused by PSFilterShim not finding the correct version of the .NET framework.

Copying PaintDotNet.exe.config into the Effects folder and renaming it to PSFilterShim.exe.config should fix that error.

  • Upvote 1

Share this post


Link to post
Share on other sites

That error is caused by PSFilterShim not finding the correct version of the .NET framework.

Copying PaintDotNet.exe.config into the Effects folder and renaming it to PSFilterShim.exe.config should fix that error.

 

I got serious issues and here are the bug file...

backtrace.txt

Edited by Nai

Share this post


Link to post
Share on other sites
2 hours ago, Virtue said:

it would be good for future versions to resolve this error in the plugin GML Matting 0.3

 

#1. Are you used GMLMatting0.3-setup.exe for the GMLMatting.8bf installation?

If yes

#2. Drag both files GMLMatting.8bfGMLMatting.ini from C:\Program Files (or C:\Program Files (x86)) to C:\Program Files\paint.net\Effects

#3. Check existence of the cxcore097.dll file in the С:\Windows\Sys or С:\Windows\SysWOW64 folder.

 

This filter works fine for me.

mattingui.jpg

Share this post


Link to post
Share on other sites
10 hours ago, ReMake said:

 

#1. Are you used GMLMatting0.3-setup.exe for the GMLMatting.8bf installation?

If yes

#2. Drag both files GMLMatting.8bfGMLMatting.ini from C:\Program Files (or C:\Program Files (x86)) to C:\Program Files\paint.net\Effects

#3. Check existence of the cxcore097.dll file in the С:\Windows\Sys or С:\Windows\SysWOW64 folder.

 

This filter works fine for me.

mattingui.jpg

 

 

thanks for answering, I did all that but does not work ,but rather opens to apply the changes It shows that error message

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.