Jump to content

Merging layers distorts transparency


Recommended Posts

Hi, good people.

I'm working on a given picture, which is derived from DDS (DXT) format. It is a texture for a 3D game model, and comes with heavy use of transparency.

As long as I work with layers, everything is fine. But when I save the file, the result is a picture with some black markings, which aren't in the original. These black spots are visible in PAINT.NET, but only after single layers are merged or the whole bunch of layers is flattened.

The damage is more easy to spot when I activate a transparency plug-in. Now even more overall changes are visible. I made a before/after picture, hope it makes a bit more clear what my problem is. The problem isn't caused by this transparency-tool, in fact it occurred as well before I installed the plugin.

I have used different parameters for blending, like "normal", "additive", "multiply", or "overlay". But this shouldn't be important anyway, because the different layers are cut-outs of the original, so no active layer overlaps with another. The changes I have done in the layers are modified values of the "hue". Can this have any impact regarding transparency?

Any thoughts or suggestions?

Thanks for listening.

post-76127-12763498592_thumb.png

Edited by Reinhard
Link to comment
Share on other sites

The layer on the bottom has to have default settings or else merging down screws up the settings.

One way to fix this is to create a new layer on the bottom of the two layers you want to merge, and merge the bottom layer down into the new layer.

Edited by Weylin
Link to comment
Share on other sites

Thanks for the hint, Weylin, didn't knew this.

But unfortunately, this doesn't help in my case. In fact, all my layers were in default condition (despite of the name) when I faced the image corruption the first time.

I just re-tried, and followed your advise to create a new bottom-layer, but it doesn't do the trick for me.

Edited by Reinhard
Link to comment
Share on other sites

Hi Sarkut.

No, a repair doesn't did the trick. As I expected, because in advance, I already did a full deinstallation and reinstall. But it is nice to know this option exists.

Version? I always use the latest release.

I just installed PAINT.NET on my netbook, for reference. Same problem.

If anybody is curious to see the image I was talking of, please see the for attachment.

Thanks.

EDIT: Sigh. I managed to ignore that the attachment doesn't worked well. My clumsy fingers on a tiny new netbook...

The file is to big anyway, so here is a direct link: please download it here, if you like (929 KB)

Edited by Reinhard
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...