Jump to content

Unreadable file upon Installation


Recommended Posts

Hello, new here.

I've been using Paint.NET for over a year now, and I have to say I really enjoy it. It's easy and helps me with all of my photo-correction needs.

However, recently, Paint.NET refuses to open. I've taken a look at other topics here, and my problem seems to be the exact same as this one. It says that there is an unsolved problem, and Paint.NET needs to close. A shortcut to the file with the codes of the issue was placed on my desktop, and I have followed its directions and emailed the file to the crash Paint.NET helper. No reply yet.

However, I uninstalled Paint.NET, and tried reinstalling it, but it won't reinstall. When I download the newest version off of this site, unzip the file, and start the installation process, it stops and closes once it is "done", and nothinhg happens. I click on the install program again, and this time it gives me an error message saying that a file cannot be read. I have the option to Ignore, Retry, or Abort. If I choose to ignore, the installation disappears, and nothing happens. The message pops up again when I click Retry, and clicking Abort closes the program.

Finally, after I go through all of the above, a different (I think) Paint.NET installation program pops up, about five minutes later. I agree to the terms of use, the installation starts, and then I get this message:

There was an error while installing Paint.NET

System.TypeInitializationException: The type initializer for 'PaintDotNet.SystemLayer.FileSystem' threw an exception. ---> System.IO.IOException: The file or directory is corrupted and unreadable.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)

at System.IO.Directory.GetFiles(String path, String searchPattern, SearchOption searchOption)

at System.IO.Directory.GetFiles(String path, String searchPattern)

at PaintDotNet.SystemLayer.FileSystem..cctor() in D:\src\pdn\pdn_35x\src\SystemLayer\FileSystem.cs:line 506

--- End of inner exception stack trace ---

So if anyone can help with this, I would really appreciate it. Yes, I believe I have the latest framework (for Windows XP), and yes, I believe I was using version 3.5.5 before the crash.

Thanks!

Link to comment
Share on other sites

  • 2 months later...

Sorry for bumping this, but hopefully this last bit of information could help. Now, when I try to download Paint.NET, it just stops at this command:

Can't write: C:\DOCUME~1\Nicholas\LOCALS~1\Temp\PdnSetup\SetupShim.exe

(Nicholas being my computer), and disappears if I click Ignore.

Any help anyone could give would be appreciated.

Link to comment
Share on other sites

Thanks for the help so far, Sarkut.

I tried everything in that thread, and nothing seems to help. However, while trying to "fix" the .NET framework in my Add/Remove Porgrams list, I found that I have several older .NET framework versions. I uninstalled .NET Framework 1.1 without any problems. But when I tried to uninstall a program with a name of something like ".NET Framework 1.1 HotFix", a message told me that I didn't have sufficient authority to uninstall it, and then it disappeared from the list.

Next, I tried uninstalling .NET Framework 2.0, which was also unsuccessful. Another message appeared, this time saying that uninstalling it would affect other programs, and that I would have to first remove those in order to remove this one. I assumed the programs referred to are the ones installed in the Framework package, which are listed below "Microsoft .NET Framework 2.0 Service Pack 2", including ".NET Framework CRT" and "Dr. Watson", among others.

I stopped there, so now I have three .NET framework packages: 2.0 Service Pack 2, 3.0 Service Pack 2, and 3.5 Service Pack 1.

I don't know if having older versions of the framework affects this problem in any way, but it's all I can think of. I've tried everything, and I'm still getting the same problem. Again, any help would be very much appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...