Jump to content

Installation on Windows 7 Fails


zhuman
 Share

Recommended Posts

Attempting to install Paint.NET 3.5.1 on a brand new clean installation of Windows 7 fails saying that .NET 3.5 SP1 needs to be installed. This is incorrect, since Windows 7 comes with .NET 3.5 SP1 preinstalled. I first suspected that the method used to detect 3.5 SP1 was flawed. However, looking at the official method of detecting the SP version (http://stackoverflow.com/questions/1990 ... -installed), I found that even though Win 7 comes with SP1 preinstalled, the registry value \HKLM\Software\Microsoft\NET Framework Setup\v3.5\SP is still set to 0. There is also a subkey to the v3.5 key called 1033 (the English LCID) which contains a SP value with the right data (1). You may want to check that localized value instead, or else check the Version value for a version number greater than or equal to 3.5.30729.4926.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...