Jump to content

Font Bug in v3.5+


dandman8
 Share

Recommended Posts

Hi all --

I'm not a graphic designer by any stretch, but I create buttons and simple images for some applications that I write. I have gotten a decent grasp of the basics and really like Paint.NET now. I think I uncovered something that behaves differently now than it did in previous versions, and it is something fairly critical for my purposes.

Write the text "Delete" with font Tahoma, size 8, bold, disable antialiasing. If you notice, the "l" shifts right next to the "e" and it just looks off. This did not happen before. I'm stuck unable to create good looking text of this size.

I'm on a Windows 7 machine.

Any thoughts? Anyone else seen this? Thanks in advance!!!

36920_e7cbc2b49587a67c709e41b2cb374dcb

36920_3025adb05253acc28143b76319836031

Link to comment
Share on other sites

Win7- Confirmed.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

If you use /disableDirectWrite parameter, you should get the behavor of previous versions.

This did the trick! Thanks so much for this tip.

I was reading up on it and it seems to be a shame that I'll need to disable this, but for my purposes, it's definitely required.

Thanks again for all the help!

Link to comment
Share on other sites

Adjustable kerning would fix this, y'know... :-P

Alas, that's probably a v5.0 feature....

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

If you use /disableDirectWrite parameter, you should get the behavor of previous versions.

How do you do this? Thanks in advance.

The easist way is to add to your Paint.net shortcut, like so.

"C:\Program Files\a\paint.net\paintdotnet.exe" /disableDirectWrite

Link to comment
Share on other sites

Right-click on your shortcut to Paint.NET and hit "Properties." Paste that code into the "target" box.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

Looks like I've got a fix that I can put in for v3.5.2.

DirectWrite lets you control the rendering mode as well as the measuring mode. The bug here is that the renderin mode was "aliased" and the measuring mode was using sub-pixel precision instead of pixel-snapping precision.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Looks like I've got a fix that I can put in for v3.5.2.

DirectWrite lets you control the rendering mode as well as the measuring mode. The bug here is that the renderin mode was "aliased" and the measuring mode was using sub-pixel precision instead of pixel-snapping precision.

That's great Rick! Thanks for taking the time to look into this!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...