Jump to content

Clone Stamp doesn't do anything

Recommended Posts

This seems like it should be an easy fix, but I've searched for a few hours and had no luck, so I thought I'd try here.

I'm using paint.net in a virtualized XP disk in Vmware's Fusion on Mac OS X (10.6.2). When I attempt to clone stamp a jpg image, nothing happens. Most of the other functionality that I have tried works, but I only really need the clone stamp function, so I haven't tried everything.

When I say it doesn't work, the image doesn't get modified. I can select the Clone Stamp tool, which gives me a circle with a crosshairs in the middle (I made it fairly large) and a small box inside the circle. When I hold down CTRL, the box inside the circle becomes an anchor-like symbol. So then when I click while holding CTRL, the anchor-like symbol goes away and it is just a circle with a smaller crosshair in the middle.

My assumption then is that I let go of CTRL and let go of the mouse button (left btn) and click the left button where I want to clone over. Pushing the left mouse button results in the smaller crosshair and the box symbol that was inside the circle, but there is no circle. And nothing happens when I move the crosshair around. It also didn't do anything if I continued to hold CTRL down.

There may be something really simple that will fix this, but I haven't found it. If you know of the solution, I would really appreciate it! Thanks!


Link to comment
Share on other sites

Yes, I understand perfectly the concept...my problem is it doesn't work. I hold CTRL and click the area to be cloned and then release CTRL and draw over the area I wish to change while holding the left mouse button...this does nothing. Maybe I should try reinstalling?

Link to comment
Share on other sites

Only managed to get it working once...

@BB...does it need to be selected first? (I know it sounds stupid but stupid questions are more easily dealt with than stupid mistakes.)

I've never really used this tool. Generally use cut/copy/paste method.

*Sigh* guess there is a FAQ or tute that deals with this.


Knowledge is no burden to carry.


April Jones, 2012

Link to comment
Share on other sites

The only simple fixes that come to mind are if you're luckily

making a simple mistake, such as, having a selection active

and trying to clone stamp outside the selection area, or,

having the wrong layer active. Probably not the case.

Repairing and/or reinstalling the NET Framework, or repairing

Paint.NET might work.

Link to comment
Share on other sites

  • 2 weeks later...

Nope, you're just doin' it rong.

Go to the area you want to use Clone Stamp. Select that area in a box selection, or lasso selection etc...

Then use the clone stamp. It works perfect within the selected area. It does not work on the whole layer, a selection must be made to work within first.

Once inside a selection area, you still have to CTRL+LEFT-CLICK to tell the clone tool what you want to clone from.

Link to comment
Share on other sites

Still no luck...I'm thinking it must be something related to running Win XP in VMware Fusion on a MAC. The other functionality of Paint.net seems to work. I can simulate the clone stamp function by doing color picker and picking the color I want and then painting over the areas to be modified with the paintbrush, but that is definitely a pain.

Link to comment
Share on other sites

Is there some format the image needs to be in? I'm just doing this to a JPG that I dragged into Paint.net as a new layer (nothing on the bottom layer). I don't think this matters, but I'm about to give up on this. The feature does exactly what I need, but it's useless if I can't get it to work.

Link to comment
Share on other sites


This suggestion may be helpful, or impractical, depending on what you are doing.

The clone stamp can be emulated by putting a copy of the image you want for

the source on a layer beneath the image you want to transfer to.

Offset the bottom layer by the amount you would have

offset the clone stamp, use the eraser

on the top layer, and merge. This way will allow

texture to be transferred which won't be possible by simply using the paintbrush.

JPG shouldn't matter.

Link to comment
Share on other sites


I'm a new user but I've also been having problems with the clone tool. What seems to be happening is when I hold done Control to select the area to be cloned, it creates two circles so I can only COPY from one circle to another (not across layers, or freely clone).

I've attached a screenshot showing the tool creating a carbon copy of the original image (on the left). The copy (on the right) is slowly being built up each time I use the tool. Obiously, if I try to 'clone' away from the original image it is just copying the canvas so it looks like nothing is happening.

I've also tried using the rectangle select to slect an area first, but this doesn't work at all (for me). The second screenshot shows the rectangle being used.

To use the clone tool, I'm holding down Control then left clicking to select then just left clicking to 'paste'.

I'm running Vista SP2 (build 6002) 64 bit and have .NET framework v3.5 Sp1 with the latest version of Paint.NET (3.5.1).

EDIT TO ADD: I've run pdnrepair.exe, which finished successfully but the problem remains.

Screenshot 1 showing the clone tool 'Copying' the original image


Screenshot 2 showing the clone tool with an area selected first


Link to comment
Share on other sites

Hi Lepton,

Here's the Help file page, in case you haven't seen it:


From what you've described the Clone Stamp may be working as intended.

In the second screenshot, nothing can be altered outside the selection area

by any tool, so that is normal. Making a selection is not necessary

for using the Clone Stamp tool.

To clone stamp between layers, change layers between setting the anchor point

and the next left-click that's applied to the canvas.

The distance and angle between anchor point and stamp point remains

fixed until you reset the anchor point. ( Ctrl + left-click )

The anchor point trails along behind where you move the mouse, that is.

After setting the anchor point, you can clone stamp either by left-clicking

repeatedly, or by holding down the left button and doing brushlike strokes.

Link to comment
Share on other sites


Thanks for the reply Sarkut, I guess I had a different idea of how the clone tool works... I had assumed that when I made a selection (the anchor point?) with Control-click, then I could clone that piece as often as I wanted, where I wanted. Would i be right then, in saying that this is not he function of the tool? Because to clone a portion of an image in several locations I would have to Control-click again in the same spot to reset the anchor point.

Thanks for the information, I can see the purpose of the clone-stamp a little better now.

Link to comment
Share on other sites

Right. Or without using the Clone Stamp, to apply the same bit of image

to many different places,make a selection of what you want to repeat and

copy it into multiple new layers, then move them one by one to where you

want them to be.

Or, save the bit that you want to repeat as a PNG file and use it as a

custom brush in Simon Brown's Custom Brush Mini plugin.

Link to comment
Share on other sites

  • 1 month later...


I have exactly the same problem as you on my home PC. However, it works fine on my work PC. The functionality of Clone really is as simple as the instructions suggest, so you're not doing anything wrong.

Have you found a cause/solution yet? I'll post anything I find.


Link to comment
Share on other sites

  • 5 months later...

Make sure there are no accidental selections in effect. I struggled and struggled with clone tool. It now works. I think I may have had an area selected without knowing it. Having unintended selections may have been what caused so may tools to appear to not work for me. I have the unfortunate GIMP habit of canceling a selection by making a small, new one. You can be sure you have no selections in effect by using the Deselect function from the Edit menu.

Link to comment
Share on other sites

Pressing Esc or Ctrl+D works too.

For some unknown reason my sig isn't showing in this thread.

Can anyone else see it? (Such as it is.)


Aha! It shows in this post, but not in the old ones.

Edited by Sarkut
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...