Jump to content

Paint.NET v3.5.1 is now available


Recommended Posts

As usual there are two ways to get it:

    1. Download directly from the website, http://www.getpaint.net/ . There is no need to uninstall the old version; that will be taken care of automatically.
    2. Preferred: Use the built-in updater from within Paint.NET. You can go to Utilities->Check for Updates, or you can wait for the following update dialog to show up automatically within the next week or so:
    20091119_pdn351installAtExit.png

Changes/fixes since v3.5:

    · New: For Windows 7, added taskbar progress reporting for long running operations (effects, adjustments, Image->Resize, save, install)
    pdn351_superbarProgress.png
    · Made some corrections to the French translation
    · Running setup with /auto will no longer launch Paint.NET when it’s done
    · Fixed an issue where Paste into New Image would refuse an image on the clipboard, even if regular Paste would take it
    · Fixed a race condition with Edit->Paste and Image->Resize whereby it would take up 100% CPU and take between 1 minute to 1 hour to finish
    · Fixed an issues with Copy/Paste where it would leave an extra line of transparent pixels on the left, top, right, and/or bottom edges
    · Fixed lag with the paintbrush tool that was being seen on some systems
    · Fixed some issues with the paintbrush and eraser tool being misaligned when zoomed in
    · Fixed a crash that would happen at (seemingly) random times, such as after drawing with the paintbrush tool, on some systems
    · Fixed a minor and obscure rendering glitch with the Move Selected Pixels tool
    · Fixed an issue with glass over Remote Desktop or Windows 7 Virtual PC
    · Fixed a minor glitch whereby the "Unsaved Changes" confirmation dialog could never finish rendering the image thumbnail if one of the Move tools was active

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

I tried installing v3.5.1 but I get a Error 1603 and it reverts back to v3.5 which I have no problems with. This is on a windows 7 64bit machine.

EDIT...Reinstalled Windows 7 and v3.5.1 is working well. Not sure if it was a .net framework problem again or what.

Link to comment
Share on other sites

Is the issue I posted about in the old thread fixed? (I would quote, but I don't know where the 3.5 thread went) It was when you changed blend mode or visibilty and it kind of stutters between if the layer your changing was full visibilty normal blend mode and what it should be.

Edit:

PDN now does this wierd thing when I flatten/merge layers. Say if I merge a layer down, and it's set to additive or whatever, then when I merge it down it flickers to as if it is set to normal, then goes to what it should look like when merged. It's only really a problem when I'm trying to compare what a layer looks like visible/not visible. This also happens when I make a layer visible/invisible.
Link to comment
Share on other sites

Is the issue I posted about in the old thread fixed? (I would quote, but I don't know where the 3.5 thread went) It was when you changed blend mode or visibilty and it kind of stutters between if the layer your changing was full visibilty normal blend mode and what it should be.

No. I looked at it for about an hour, but couldn't pin down what the specific problem in the code was. Since the other fixes were very important, I decided to release 3.5.1 now with them, and wait for another release to fix the issue you brought up.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

new guy here,,been using paint.net for about 3yrs,,,GR8 tool n the BEST,,allways my tks to you Rick for updating and keeping on top of things n for your Hard Work in doing so. is there a way to the opening boxes like effects-layers-adjustments,ect, so they dont open in the middle of my work so i dont have to move them each time to work.

again tks tons Rick

Link to comment
Share on other sites

What a surprise - another update so soon. I swear that v3.5.1 is now working much faster than before. Thank you. It's still not "remembering" thumbnails* but, as you said this may be particular to Windows XP, I am learning to live with it.

Thanks for the continued improvements.

:)

* Actually, I take that back. I've noticed that it will remember thumbnail now, if I view a folder within a folder.

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

· Fixed an issue where Paste into New Image would refuse an image on the clipboard, even if regular Paste would take it

· Fixed a race condition with Edit->Paste and Image->Resize whereby it would take up 100% CPU and take between 1 minute to 1 hour to finish

Thanks

That was a program killer :mrgreen:

CjW

Edit by Rick: Sorry, no flashy animations in avatars or signatures.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...