Jump to content

HOW TO INSTALL PLUGINS/General Plugin Troubleshooting Thread


RaveN
 Share

Recommended Posts

I suggest asking a mod to put it in the sticky'd installation topic in this section.

I was thinking about that. I'll send a message out.

I might make a tutorial for using WinRar + Plug-in packs.

---- Gallery | Sig Tutorial | deviantART | Sig Videos | PhotoBucket ----

D                  E                  S                  T                  I                 N                  Y

Link to comment
Share on other sites

Aren't they installed in practically the same way? Also, all the plugin ZIP files i've seen here unzip with the one included with Windows ME and later.

I guess so. Maybe I won't do a video. Less work for me. :D

---- Gallery | Sig Tutorial | deviantART | Sig Videos | PhotoBucket ----

D                  E                  S                  T                  I                 N                  Y

Link to comment
Share on other sites

I was trying to download a plugin and it said this

Extracting to "C:\Program Files\Paint.NET\Effects\"

Use Path: yes Overlay Files: no

Error: Access is denied.

Cannot create C:\Program Files\Paint.NET\Effects\Shape3D.dll.

Administrative privileges may be required

can any one help :?: :?: :?: :?:

Link to comment
Share on other sites

You may need to "unblock" the file. Read this: viewtopic.php?p=23198#p23198

Then read this: viewtopic.php?p=45862#p45862

Link to comment
Share on other sites

I hope someone will help us. We have been using paint.net for a few months and we cannot get ANY plugins to work. I have carefully followed steps to unblock and unzip from desktop and tried to drag into paint.net.

We are using vista. The plugins are "TileFill from Clipboard2" and "anti alias plugin jchunn"

I tried to put them into effects. Only the tile one has a dll file. They other, I did not see one.

Please speak slowly and clearly. :D

I really hope you can help. Thanks. :D

Link to comment
Share on other sites

kelly:

Just now I downloaded and installed both plugins you refer to, both work.

I also use Vista. Most likely there is something very specific that you are

doing or not doing that results in the difficulty.

You write:

"we cannot get ANY plugins to work."

Have you tried several others, and none work?

"tried to drag into paint.net."

Is Vista failing to execute the drag-and-drop?

Are you placing the plugin .dll into the PaintDotNET Effects sub-folder?

Do the plugins not show up in the Effects menu of PdN, or do they appear

where they belong, but are non-functional?

What version of PainDotNET are you using?

Is your Vista OS up to date on Service Packs, etc?

More information is needed.

Link to comment
Share on other sites

Thanks,

I'll clarify.

these are the only 2 I have tried.

The drag and drop looks like its working fine. But plugin never shows up anywhere in paint.net.

You ask: "Are you placing the plugin .dll into the PaintDotNET Effects sub-folder?"

As I said, I did that for one of them only because I could not see a dll for the other.

Yes Vista is up to date. What version of pdn? I am not sure how to tell. It was the most recent when I downloaded it about 6 months ago.

Have done it over several times to try different things. What else can I try?

Link to comment
Share on other sites

kelly:

Thanks for the clarification.

The download for AntiAlias is the .dll itself.

Perhaps you downloaded the Source Code.

Try downloading the .dll again.

The download link is just below the kitten pictures.

Most likely you do have the current version of PdN, you can check for sure, by opening

PdN, clicking Help > About.

Also, is there anything in the Effects folder other than the Tile fill .dll? If so, what?

Edited by Sarkut
Link to comment
Share on other sites

Inside effects folder:

jchunn DLL file

tilefrom clipboard2 SLN file

tielfrom clipboard2 file folder

PDN:version 3.3x

I cannot find a dll for the tile one anywhere right now. And neither are working. I have already "unblocked" them and I just re-checked that.

I have tried re-downloading, but I guess I could again.

Kelly

Link to comment
Share on other sites

kelly:

Remove the "tile from clipboard2 file folder".

Also remove the "tile from clipboard2 SLN" file.

The "tile from" file should be a .dll file.

==============================

Download the Tile Fill .dll here:

Link is in the Attachments box in the first post.

Says "TileFillFromClipboard.zip [5.47 KiB]"

===============================

[Edit]

Goal is to have only these two in Effects folder:

Antialias_v1.5.8.0.dll

TileFillFromClipboard.dll

Edited by Sarkut
Link to comment
Share on other sites

We put the anti alias in again. I had gotten it from the same kitty page.

It is in the folder and in the pdn now. It looks completely different. But I think it's not working.

We enlarged the image and tried the effect both with and without selecting an area first. We put the controls at full strength, I think. We even repeated 5-10 times to see whether we could detect any effect. No go.

Thank you for your patience. :)

Link to comment
Share on other sites

kelly:

Progress!! :)

Now that the Antialias situation is no longer an installation problem,

you need to make a new post in the Antialias plugin thread, so it will

come to the attention of the plugin author.

Best Wishes.

Sarkut

.

Edited by Sarkut
Link to comment
Share on other sites

Spencer:

From your video it looks like you have an Effects folder and a File Types folder inside your Effects folder. This isn't normal. The PdN Effects folder should have only plugin files in it, not folders. Remove those extra folders and try again.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Link to comment
Share on other sites

  • 1 month later...

Hi. I've been working with paint.net for almost a year, and I'm new to the forums. I'm trying to unblock "Advanced Tools by LFC" and I can't figure out how. At fisrt I opened it, it was just like all the other plugins, and when I clicked the popup window, it said it was an april fools. I came here to see what other people had said about it being a 'joke', come to find that they can actually use it. Now I've been trying to figure this out for a while now, maybe half an hour, and still can't figure out how to get it to run. They say to read the ReadMe file, but all I see is a smiley face. Can you help me? This is really the only plugin I've had trouble with. I'm using Windows Vista. :oops:

Forum%20Siggie_.gif
Link to comment
Share on other sites

I'm trying to unblock "Advanced Tools by LFC" and I can't figure out how. At fisrt I opened it, it was just like all the other plugins, and when I clicked the popup window, it said it was an april fools. I came here to see what other people had said about it being a 'joke', come to find that they can actually use it. Now I've been trying to figure this out for a while now, maybe half an hour, and still can't figure out how to get it to run. They say to read the ReadMe file, but all I see is a smiley face.

Rest assured it was/is an April Fools joke. There is a plugin, that does nothing - as you found out. The references you found to people using it was an attempt to perpetuate the joke.

You can relax now :D

For a bit of a laugh, check out this reaction: viewtopic.php?f=10&t=31885&start=0. "Homicidal-rage inducing CUTE" -priceless :lol:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...