Jump to content

HOW TO INSTALL PLUGINS/General Plugin Troubleshooting Thread


RaveN
 Share

Recommended Posts

ok.. im new this so if i do something wrong its coz im new ok..

i can add the tools fine right

but i cant add text..

i do what it says

extract .. open up program files.. paint.net then i put it into "FileTypes" but it does nuthing from then..

any help please?

Link to comment
Share on other sites

If you're talking about fonts, you need to read this thread.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

Okay so i went to the site for the plugin download...downloaded it, exracted it, and sent it to effects! but its not showing on paint! what went wrong or how can i fix it?! plz help asap! :x

Try, going to the Downloads Folder, copy and paste in Program Files »Paint.net »Effects.

Link to comment
Share on other sites

Try, going to the Downloads Folder, copy and paste in Program Files »Paint.net »Effects.

Yes I tried that already!

What's the name of the effect ? And by "site for the plugin download", do you mean the PDN forum ?

I downloaded the splatter effect and its cs file! i downloaded from the link posted on the forum! it was pyrochild splatter v1.1

Link to comment
Share on other sites

Are you sure you put the DLL, and not the ZIP or the CS (or the EXE installers) ?

Are the DLL in the Effects folder, or in the FileType folder for the filetypes ?

If you downloaded Pyro's plugins, have you downloaded "pyrochild.effects.common.dll" too ?

And if you have Kris VDM's plugins, do you have "Vandermotten.PaintDotNetEffects.dll" ?

And Ed Harvey's plugins need the two dll to work.

Finally, have you anything in the File menu, like "Show plugins loading errors" (don't know what is it in English, made a translation...) with a green icon next of it ?

Link to comment
Share on other sites

...and are you sure that you have NONE of the Paint.NET program-specific dlls in the Effects folder?

Make sure that "PaintDotNet.Base.dll," "PaintDotNet.Data.dll," "PaintDotNet.Core.dll," "PaintDotNet.Effects.dll," etc. are not in the Effects folder.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

  • 3 weeks later...

I've encounted a problem with two plug-ins. Previously, I've managed to do this OK but today

I dowloaded a Smudge and Splatter, and after extracting them I did this:

Find Program files, and find Paint.NET, and find effects, place the .dll file in there

They went into Paint OK but when I try to use either one I get a "plug in error" saying I should close PaintNet and restart. I've done this to no avail.

:(

edit: It's OK - after re-installing the tools it now works. :lol:

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

  • 2 weeks later...

ok bassically im new to paint.net

and i want to download the plugin : conditional Hue/Saturation Adjustment

so ive downloaded the file to a folder on my computer, ive tried to extract it but it comes up with a message that it cannot be read :S

so anyway i tried instead moving the download straight to effects in my c drive and it isnt showing up when i load paint.net

can anyone suggest what i am doing wrong?

thankyou :)

Link to comment
Share on other sites

Hi. Very first post here and I have what by now must seem a very repetitive question. I'm running Windows Vista, Service Pack 1. My PC meets or exceeds all the system requirements given for PaintNet. I downloaded BoltBaitPack for the feather tool and then extracted it to the effects folder. Then I too couldn't find the effects upon opening PaintNet. I looked in the effects folder and at first glance it said the folder is empty. Screen shot:

beforeclickingcompatibility.jpg

I tried again...same result. Then I noticed the wee "compatibility files" icon. I clicked it, and voila...there they were.

compatibilityclicked.jpg

I was able to right-click properties and unblock them all and at this point I thought my problem was solved but neither opening-reopening PaintNet nor restarting my PC nor running PaintNet as administrator will make the effects show up.

I have PaintNet Version 3.36...so now what am I doing wrong?

Link to comment
Share on other sites

To me those look seperate folders. Open the origional and copy the files from that one into it.

They actually are separate folders. The answer to why they are I found here:

To keep legacy apps running, Vista lets them pretend to write to their familiar file locations often under their installation folder in \Program Files or in \Windows itself. INI files, data files, templates, or even music might wind up there.

But when you go to look for those files, you won’t find them! Vista actually stores the files in a “Virtual Store” under the AppData store in your user folder. Fortunately, you don’t need to hunt around for the files, just turn on “Compatibility Files” in Explorer. When you browse to a folder that has these hidden files, you’ll see a Compatibility Files toolbar button. Clicking it will show the virtual files for that folder. Keep in mind, though, that the files won’t show up in Open and Save dialogs.

Unfortunately, they don't say much about what to do about it. Vista sticks them in that "virtual store" section and it seems PaintNet can't find them there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...