Jump to content

HOW TO INSTALL PLUGINS/General Plugin Troubleshooting Thread


RaveN
 Share

Recommended Posts

Frangipani_LOL, have unzipped the DLL? Have you unblocked the DLL (if applicable)? Have you put the right DLL in the right folder - a file type in the FileTypes folder, effect in Effects? Have you restarted Paint.NET? Have you the latest version of Paint.NET, 3.36?

If you're wondering 'what's with all the questions', it's because you've only given us one piece of information: you put something into the Effects folder. There are many possibilities with what could have gone wrong, we can't make an accurate assumption with just that.

Link to comment
Share on other sites

Hi I am haveing a very odd problem. I am attempting to install a plugin, one for using .vtf files, and it says that it encountered an error. This is as follows:

1 of 1

--------------

File: C:\Program Files\Paint.NET\Effects\VtfFileType.dll

Effect Name: ImageFormatInfo

Full error message: System.TypeLoadException: Could not load type 'ImageFormatInfo' from assembly 'VtfFileType, Version=1.0.4.0, Culture=neutral, PublicKeyToken=null' because it contains an object field at offset 4 that is incorrectly aligned or overlapped by a non-object field.

The weird part about this is, is that on my friends computer, the plugin works, and when I had my old computer it worked as well. However now it does not. If anyone knows why, or how I could fix it, any information would be much appreciated. I put the 2 .dll's in my effects folder, and I tried putting them in filetypes, thats where I put them when it did work, however neither worked.

I am running 64 bit Vista, this is most likely the problem as far as I can see, but I may be wrong.

Link to comment
Share on other sites

I need help with all plugins. I had downloaded some plugins and I had them working just fine in my paint.net. I downloaded a plugin package with a few plugins and then my Paint.NET kept saying "paint.net has encountered a problem and needs to close." It kept saying that so then I reinstalled paint.net. Since then I have to redo the plugins and everyone that I try I do the same way that I did the first time but they dont show up in my effects or anywhere else for that matter. Please help

Link to comment
Share on other sites

they dont show up in my effects or anywhere else for that matter. Please help

Can you post the content of the File > View Plugins Errors dialog?

File: C:\Program Files\Paint.NET\Effects\VtfFileType.dll

I am running 64 bit Vista, this is most likely the problem as far as I can see, but I may be wrong.

The plugin just don't work in x64. Contact the author.

EDIT More constructive constructivism:

You should download this guy's stuff, as it's a single application, it will use Windows On Windows 32bit emulation.

VTFEdit is a C++ .NET graphical frontend for VTFLib with viewing and creation capabilities.

http://nemesis.thewavelength.net/index.php?p=40

No. Way. I've just seen Bob. And... *poof!*—just like that—he disappears into the mist again. ~Helio

Link to comment
Share on other sites

  • 3 weeks later...
Frangipani_LOL, have unzipped the DLL? Have you unblocked the DLL (if applicable)? Have you put the right DLL in the right folder - a file type in the FileTypes folder, effect in Effects? Have you restarted Paint.NET? Have you the latest version of Paint.NET, 3.36?

If you're wondering 'what's with all the questions', it's because you've only given us one piece of information: you put something into the Effects folder. There are many possibilities with what could have gone wrong, we can't make an accurate assumption with just that.

So once the plug ins are installed, they show up in the effects area? or no?

Link to comment
Share on other sites

I asked about this and got it locked with no reason...

Im trying to use a custom brush.

I know the procedure, of taking it into the custom brushes folder.

.....I do not have a custom brushes folder.

never did.

HELP PLEASE.

that is all I ask.

Run the plugin, and it will be created in: My Documents\Paint.NET User Files\Custom Brushes

sigxz7gs5.png

My DA: http://leif-j.deviantart.com/

--------------

Some people seek justice so persistent, that they will do great injustice themselves.

Link to comment
Share on other sites

Hi,Nascaraddicts93..

I just solved the my problem just now..same with the trouble you had..

~Here is what i do:

-Go to the Effects Folder..*can you see another folder contains the effects that you just download?

-Open it..copy all inside that folder

-Go back to the Effects Folder and paste it all there..

Then try to open your paint.net again.Hope this can help you out of the trouble. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...