Jump to content

upgrading to 3.5 stuck on uninstall


alexo
 Share

Recommended Posts

This happened to me with all the 3.5 betas and today with the final 3.5.

The installation of a new version tries to uninstall the existing one first.

When the uninstall progress bar reaches about 100%, the (un)installer hangs, using a lot of CPU but seemingly doing nothing.

Using the SysInternals ProcMon shows that the MSI process apparently tries to open each every registry key in existence.

Killing that process allows the installation to continue.

Link to comment
Share on other sites

  • 2 weeks later...
This happened to me with all the 3.5 betas and today with the final 3.5.

The installation of a new version tries to uninstall the existing one first.

When the uninstall progress bar reaches about 100%, the (un)installer hangs, using a lot of CPU but seemingly doing nothing.

Using the SysInternals ProcMon shows that the MSI process apparently tries to open each every registry key in existence.

Killing that process allows the installation to continue.

Same thing happened when upgrading to 3.51.

Anyone?

Link to comment
Share on other sites

I tend to install fair amount of trial versions of applications, play around with them and uninstall them before the trial period expires. I am not claiming my experience to be universal but I have never encountered such behaviour in other applications. It may not be a bug per-se but I'd file it under the "undesired behaviour" category.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...