Jump to content

V 3.5 Installation hangs (process responding) permanently


imamgholi
 Share

Recommended Posts

Ok, been a silent and happy freerider so far and now finally had to register, so, hi yall! :D

I just tried to update mine to 3.5 initially using the update popup offered by paint.net, and the installation/update halted at about half an inch to the end of the progress bar, i would assume in 90-100% zone of the progress. it just stops and never moves again without the process every becoming "not responding"

so i went ahead and pulled the plug on it, got some error that i did not read carefully about something in c++ missing and the installation trying to repair it and rerun itself again. but nothing happened after i said ok. then i tried running it again, this time hitting other errors that an earlier installation needs to be finished and i just have no idea how to finish it, tried running the temp folder paint.net update file and that didnt work either.

I checked everywhere i could on the forum, reinstalled .net fmwrk 3.5 clean+got updates, tried the MS installer cleanup, and tried to manually clean anything left of paint.net in the registry and elsewhere on my pc... all to no avail

long story short, i did a system restore-recovery to pre-update times. uninstalled both paint.net and .net fmwrk, reinstalled .net fmwrk+reboot+update+reboot, then got paint.net 3.5 full installation, and now once again my new installation has stayed dead in its track at the very same spot it did earlier today. please advise me on what could possibly be the problem and how i can fix it.

refer to the scrnsht to see it for yourself (this is my 2nd try), as i type this, the progress has been stopped there for the past 45 mins. hard disk activity has been constant (i got all indexing off, no malware, and on my earlier try i had no other programs running- i know u might say something about my taskbar activities regarding hdd blinks)

so as u see, there is a serious issue here, repeating itself-which i'm guessing could be either of the following:

- somehow a still corrupt .net fmwrk on my system

- a corrupt installer/file download (even with a 2nd download? from pdn site?)

- a bug

- some other 3rd factor resulting in this behavior by the installer

ps. ms installation wizard is working just fine with all other setups.

thnx in advance

35620_cf4ec7f73945787228e88abc07c1008c

Link to comment
Share on other sites

You say that hard drive activity is still continuing while it's at that point ... how long have you left it alone, to see if it eventually figures itself out?

It might just be some component taking awhile (the C++ runtimes, like you mentioned, possibly).

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

the hdd activity went away for the most part when i closed down all other active programs, at least it was not as constant as it used to be... however, it took the installation another 20-30 minutes (total of over an hour) to stay dead in its track... and i eventually had to terminate it as i needed to take my notebook and head out.

among the previous errors associated with this problem are: 1618 & 1603/1610. i'm positive on 1618, and 95% sure about the other one.

its 4 am here, i will fool around with it 2moro when i get a chance and if i totally had to go thru the same path as it seems so, this time i will document it all with details.

i love pdn goddamit and am in no shape or method ready or willing to switch to any premium and more advanced software now, plz help me with this issue!!!

Link to comment
Share on other sites

ok, this is not working despite all the tricks.

I have restored my pc to a week ago

I have completely removed MS .net+reboot

cleaned up any existing .net or pdn setups using the MS cleanup tool

cleaned up registry using wise registry cleaner

i downloaded the full distributable package of .net 3.5sp1

installed and reboot

got the two updates

tried installing older pdn 3.36 and now I get this error (see screenshot)

I had my registry backed up before cleanup and so i fully restored, but i tried again and got the same exact error. terminated win installer and pdn setup process. tried installing 3.5, which resulted in the same circumstances mentioned in previous posts.

35620_d1307688a9f16ed76313200d30518567

Link to comment
Share on other sites

well, this is something!!!

just before i made the last post, i almost forgot to censor my posted image (i assume your rules ban bad language) and when i right clicked and chose edit as i usually do, i got another clue to this problem (refer to image untitled2).

so, what could it be, and how can i fix it?

trying the repair button resulted in the 2nd deadend (untitled123)

35620_5b9bef7f8fc96e75d2aba23593803e55

35620_d1eb384c73385cfa8796fcb36e251163

Link to comment
Share on other sites

ok, so i went ahead and uninstalled all c++ entries in programs & features, and redownloaded them manually and tried to implement them. however, one of the setups acts very similarly to the pdn 3.5 problem which was a permanent hang (process still responding though) at the very last stages of the installation. please refer to the scrnsht to see what i mean.

it has been this way for quite sometime and i got NO HDD ACTIVTY

EDIT: if it may help, I should mention while i tried to install these c++ setups, initially i was given an error telling me pdn installation is suspended and changes made by it need to be undone so that c++ setup could continue which i replied yes (undo) to

35620_28dd2ef824232a6f0fa7b40ff0c73f90

Link to comment
Share on other sites

alright v 3.36 and 3.5 are out the window as of now. i have pdn files that i must work on ASAP, in fact i'm late on those. i have downloaded pdn v3.07 and this one is just fine. after i'm done with my work, i will try an upgrade on over this one, so maybe i can get somewhere.

but i would still very much appreciate any solution to the problem as mine is quite the temporary one, plus i want to see this new version that everyone is saying looks so good!!!

Link to comment
Share on other sites

oh btw is there a way i can get a portable version ready for download and run the new version from a usb? or any other method that i can run the new version but without having to locally install it? any method would do, i'm advanced enough as a windows-savvy user (know nothing in programming tho) to be able to implement any complicated yet working solutions/workarounds.

as for the ddsfiletypes.dll i noticed a folder was in my program files named paint.net, i assume this file was one of those missing files in this folder as there a bunch of other dll files and folders inside it. i really do not want to go for a whole mess of reinstalling windows, and am not even sure what the problem is. however when i get some time i may try a clean boot and go from there to see if anything is conflicting

also do u think it is a good idea to try installation in safe-mode, technically it shouldn't be according to what i know, but i have heard this over tech support lines and elsewhere on the tech support forums that in certain instances it could be a solver

PS. i don't wanna sound like i'm asking for a dedicated premium tech support for free, but if this sounds nearly as a bug and yall as developers have enough interest and time at the moment to find it further whats going on, i'm down for a teamviewer session. however, for now v3.07 is enough to let me handle my liabilities

Link to comment
Share on other sites

  • 2 weeks later...

Glad it all worked out successfully. Props. :-)

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...