Jump to content

Paint.net Copy and Paste show odd pixel on left of screen


Recommended Posts

I found a bug on copy and paste function together with RDP session.

Here is issue.

Install Windows XP + SP2 eng. (have not tested it on SP3)

RDP client version is 5.1.2600.2180

Install dotnet 3.5 sp1.

install paint.net 3.36 latest release. (Paint.NET v3.36 (Final Release build 3.36.3158.38068)

Install terminals 1.7e from codeplex

http://www.codeplex.com/Terminals

Launch Terminals 1.7e, next RDP to any server. Do a "Ctrl-Print Screen".

Now come back to the local desktop and launch winword or excel, and paste.

It works just fine.

Next launch Paint.net and paste.

Now the image shows per attached. :oops:

539_a16b3d672c31cd793e32f3fe6d6511dc

Link to comment
Share on other sites

I found a bug on copy and paste function together with RDP session.

Here is issue.

Install Windows XP + SP2 eng. (have not tested it on SP3)

RDP client version is 5.1.2600.2180

Install dotnet 3.5 sp1.

install paint.net 3.36 latest release. (Paint.NET v3.36 (Final Release build 3.36.3158.38068)

Install terminals 1.7e from codeplex

http://www.codeplex.com/Terminals

Launch Terminals 1.7e, next RDP to any server. Do a "Ctrl-Print Screen".

Now come back to the local desktop and launch winword or excel, and paste.

It works just fine.

Next launch Paint.net and paste.

Now the image shows per attached. :oops:

Link to comment
Share on other sites

I found a bug on copy and paste function together with RDP session.

Here is issue.

Install Windows XP + SP2 eng. (have not tested it on SP3)

RDP client version is 5.1.2600.2180

Install dotnet 3.5 sp1.

install paint.net 3.36 latest release. (Paint.NET v3.36 (Final Release build 3.36.3158.38068)

Install terminals 1.7e from codeplex

http://www.codeplex.com/Terminals

Launch Terminals 1.7e, next RDP to any server. Do a "Ctrl-Print Screen".

Now come back to the local desktop and launch winword or excel, and paste.

It works just fine.

Next launch Paint.net and paste.

Now the image shows per attached. :oops:

Link to comment
Share on other sites

I found a bug on copy and paste function together with RDP session.

Here is issue.

Install Windows XP + SP2 eng. (have not tested it on SP3)

RDP client version is 5.1.2600.2180

Install dotnet 3.5 sp1.

install paint.net 3.36 latest release. (Paint.NET v3.36 (Final Release build 3.36.3158.38068)

Install terminals 1.7e from codeplex

http://www.codeplex.com/Terminals

Launch Terminals 1.7e, next RDP to any server. Do a "Ctrl-Print Screen".

Now come back to the local desktop and launch winword or excel, and paste.

It works just fine.

Next launch Paint.net and paste.

Now the image shows per attached. :oops:

Link to comment
Share on other sites

This bug has been reported a number of times.

EG: viewtopic.php?p=207093#p207093

From what I can tell there is no real way to fix it. It is belived to be due to other apps, clipboard data, and other factors.

Other words, if you can pin point it down to a program or something your doing, it best to avoid doing it if you don't want this problem to occur.

Link to comment
Share on other sites

  • 5 months later...

Tks for the reply.

I check the problem is still exist in v3.5.1 client.

I tested it under Windows Server 2008 R2 with dotnet 3.51 setup.

From W2K8R2, open up the default RDP client v6.1.7600, connect FULL Screen to any remote computer, and then inside the remote RDP session, launch the Windows Explorer, and then capture the current window by pressing "Alt" + "Print Screen" buttons, next return to the local W2K8R2 server and paste that capture onto Paint.Net v3.5.1.

Actually, the issue does not occurs if you paste it onto MS Word or MS Paint.

539_812d02e625f3756be896c3c7fe8d5e29

Link to comment
Share on other sites

  • 2 months later...
  • 6 months later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...