Jump to content

HELP! Can't reinstall PDN

Recommended Posts

Hay guys.

for some reason Paint.Net got removed from my computer. when I tried to reinstall the latest version (which i already had installed) i kept getting one or other of these errors.

Error 1:

There is a problem with this Windows Installer package.

A program required for this install to complete could not

be run. Contact your support personnel or package vendor.

Error 2:

A network error occurred while attempting to read from

the file:


Those are the error boxes exactly as they appear on the screen.

I have tried different Paint.Net installer files. I reinstalled the .NET Framework 3.5 SP1.

What else can I do?

Link to comment
Share on other sites

Just hit the update button thing and it said that there was one update so ill install that and see how things go.

UPDATE: I installed every available update for Vista including the optional ones and i still get the same errors.

What else can i do to fix it?

I have had V3.36 installed on this computer before and nothing has changed since it was uninstalled.


I just looked at the add/remove program thingy and there is a PDN thing there. I tryed uninstalling it but i get the same errors.

Is there anything i can do?

UPDATE 3: The 3rd, and final.

I have sort of solved the problem. I stole the Paint.NET folder off the other computer that we have and put it where it should go and this has sort of solved the problem. I still cant unistall it via the program and features menu but ive got PDN back so yeah. Any help on how to fix that part of the prob will be helpful.

Link to comment
Share on other sites

Yeah i had all that but it still doesn't work so i just did a system restore but then stupid vista crashed. Dam vista!!!! i no exactly whats wrong but don't have the tools to fix it. Haha. so its going into a friends to get fix so that should fix the prob with PDN to.

Link to comment
Share on other sites

  • 2 weeks later...

you could find a solution in one of the posts:




even though you may have vista, the solution to one may work in vista..

if you have net framework 1, 1.1, 2, 3.1, 3.5 etc..etc.. you may still be able to get it to work using the one method mentioned of uninstalling all of them then reinstalling in numerical order..I would suggest first that you get the net frameworks for which you can download and install manually from Microsofts website

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...