Jump to content

No Longer Shows Image Pasted Into New Layer?


Go to solution Solved by DHGamerMR,

Recommended Posts

I routinely use paint.net to do collage style images of game characters, where I'll have a large main image as the background, then I'll paste smaller images around the focal point of that background as new layers, showing additional details not visible in the main image. Takes me two or three minutes to put one of these together after I gather the source images, and it's a quick and easy process I've followed for close to a decade now. Today I did one of those projects, shared the result to some friends, and saw I had an update to 4.3.12 available.

 

Cool. I'll close out and update, as usual. 

 

The update installed and I had a request for another of these, so I went in and did exactly what I normally do, but now the new layers show up as containing no image. It's just showing the selection rectangle now but not the image that should be inside that selection. Checked all the layer properties to make sure it hadn't somehow defaulted to zero opacity or something equally stupid. Saved the file and reopened it. Started a new file again, this time creating the new layer manually and then trying to paste the new image into that layer. Made sure again that I have the right layer selected to add to, but still nothing showing.

 

Anyone know what might have broken here from one release to the next? I'm hoping there's just some option or setting that's been inexplicably changed and hidden away in preferences I can't find. 

troubleshoot001.JPG

Link to comment
Share on other sites

19 hours ago, DHGamerMR said:

The update installed and I had a request for another of these, so I went in and did exactly what I normally do

 

I don't understand this comment, that you updated and then had a request for another of these?  Does this mean you downloaded/installed paint.net twice?

 

19 hours ago, DHGamerMR said:

but now the new layers show up as containing no image


It sounds like you have nothing on your clipboard.

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

Are you sure you're copying a visible layer prior to the paste?

 

Try 

 

Ctrl + Shift + C as your copy shortcut (copy all layers aka copy merged)

 

Pasting: Ctrl + Shift + V (paste into new layer)

Link to comment
Share on other sites

  • Solution

 Thanks for the replies and suggestions, all. Uninstalled and reinstalled paint.net this morning, and everything works now. Seems to have been a borked update. Only answer I can find to this. 🤷‍♂️

 

Just to clarify (especially in case it will help someone else), I tried/checked the following.

 

1. Yes, it was the active layer, and it was on top. I should have expanded my screenshot to include that. I tried rearranging the layers to see if the order was somehow borked. Also checked opacity was set correctly in the layer properties. No joy.

2. I tried copying/pasting as a new layer directly to my target image from the Windows Snipping Tool (which I usually do). I was able to copy/paste into a new image from the Snipping Tool (image at left in the three at top of my screenshot). Tried to copy/paste from that image into a new layer in the target image. No joy.

3. I tried Ctrl+Shift+V to paste into a new layer, as I usually do. When that didn't seem to work, I added a new layer manually and then tried to paste into that new layer.  I tried by keyboard shortcut and from the Edit menu. Still no joy.

4. There was definitely data in the clipboard, as I was able to paste the image into an email, a Discord message, and a new image in paint.net. 

5. Tried starting from scratch again this morning with new images. Still no joy. Uninstalled and reinstalled after that.

 

No noticeable software issues outside of paint.net during all of this, including extensive time spent yesterday in Blender, Movie Studio 17 Platinum, Audacity, and DaVinci Resolve. 

 

System info:

OS: Windows 10 Pro 

Processor: Intel i7-8700K CPU @ 3.70GHz

RAM: 64.0 GB

GPU: GTX 1660 6GB

 

All drivers appear to be current.

 

Again, I don't know what caused the issue, just that uninstalling and reinstalling appears to have fixed it. 🤷‍♂️

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...