Jump to content

nVIDIA Prompt Keeps Appearing

Go to solution Solved by toe_head2001,

Recommended Posts

I'm currently using version 4.3.7¹ on my all-Intel Windows 11 desktop PC (upgraded free a few months ago from Windows 10), and every time I perform certain operations, like resizing an image using hotkeys, an nVIDIA prompt keeps appearing "babbling" stuff at me about how to use its overlay...when I'm not eve calling the nVIDIA interface.



MBD:        MSI Z490-A Pro (MS-7C75) w/Intel Z490 chipset
CPU:        i9-10900F 2.8 GHz 10-Core/20-Thread (water-cooled)
GPU:        nVIDIA (Gigabyte) GeForce GTX-1660 Super Windforce / 6 GB GDDR6
RAM:        16 GB Crucial Ballistix UDIMM Gaming Memory, DDR4/3600 1.3V
OSD:        Crucial NVMe M.2 2 TB SSD (2400 MB/s)
PSU:        750 W EVGA 80+ Gold
OS:        Windows 11 x64 Home 21H2
Network:    EP-9636GS EDUB LOVE Wi-Fi 6 / Bluetooth 5.1 3K Mbps


It's not a problem, actually, as I simply try to ignore the irritating message, but it's a bit annoying, but on the off chance that anyone knows what's causing it, maybe such a person could tell me how to eliminate the petty annoyance? I keep all of my drivers up-to-date, but I've noticed that there's a new Paint.NET version. I've downloaded it, but haven't yet installed it (I'm reluctant to, as I might not like some changes).


PC user since 1984

¹ (EDIT) I've just installed the newest version, and find that this problem happens with it, too.

Edited by gremlinkurst
NFO RE: latest version
Link to comment
Share on other sites

10 hours ago, toe_head2001 said:

In the Nvidia software look for the option to disable the overlay.



Thank you. Not quite what I was looking for, a way to eliminate the actual error, but this works, too, treating the symptom, not the disease. No more hiccoughing, sneezing, and farting at the same time- whee! I know the fault isn't with Paint.NET; the nature of the problem lies squarely in the driver-coders' bailiwick (somebody was a lazy coder; instead of writing all of his own code, some "rocket surgeon" at nVIDIA thought it a sound practice to use code blocks already present and ready to be called from system nooks and crannies! My professor back in the day regarded that practice as 1) lazy, and 2) plagiarism- write your own darned code!).

Edited by gremlinkurst
accidental emoji (again!) guess I know what B) does
Link to comment
Share on other sites

  • 1 year later...

@Dahoom - I realise that you were trying to help but the last post here was a year and a half ago and the OP's problem was solved. Please don't revive old threads.

See the Forum Rules (link at the top of this page) and note rule #11.

Also, it is not clear whether your advice to use the nvidia control panel to set paint.net to use integrated graphics instead of the dedicated GPU will interfere negatively with the options that paint.net already provides - see :Settings: Settings | Graphics 'Use hardware acceleration...' and 'Rendering device'.  It may well be OK but, if not, it may result in a large performance penalty for paint.net.


Link to comment
Share on other sites

8 hours ago, Dahoom said:

What worked for me is setting paint.net to use integrated graphics instead of my dedicated GPU via nvidia control panel.


That's also a very poor idea for performance reasons.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...