Jump to content

with only one layer, create layer and use Ctrl+Z to undo: delete layer button is still enabled


Recommended Posts

I don't know why I'm finding all these micro bugs now.

Repro steps:
1. Open paint.net
2. Create a layer
3. Undo

You'll notice the delete layer button (and move layer up button), which should be disabled because there's only one layer, are still enabled. Clicking either of them will just disable the buttons. Repros in version 4.3.4. Windows 10 Home, non-store version

Bonus bug that's so micro it doesn't warrant a fix: hovering over the image thumbnails of the open images in PDN will block you from typing text with the text tool. Assuming it just eats the keypress event.

Anyway since it's almost Xmas and New Year's, happy holidays :)

Link to comment
Share on other sites

The first issue repros for me, I'll see about fixing that for 4.3.5

 

Hovering the mouse over anything will generally capture the input focus, so I'm not surprised about the thumbnails. Will also happen with items in the toolbar. It's not really a bug, it's just how things had to work.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...