Jump to content

While updating paint.net I get a failure code of 1603. ...


chonorof
 Share

Recommended Posts

Are you updating through the app's built-in updater, or trying to install the MSI directly?

 

It looks like the post-install custom action is failing with 0x80070005, which is just a generic E_FAIL.

 

You should have two more logs files in %TEMP%, pdnSetupShim.log and pdnSetupActionsInstall.log file. Post those and I'll take a look.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

11/15/2021 11:58:04 AM - setting registry value: HKEY_CLASSES_ROOT\paint.net.1\shell\open\command\(Default) = ""C:\Program Files\paint.net\paintdotnet.exe" "%1""
11/15/2021 11:58:04 AM - *** ERROR: Unhandled exception: System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.
   at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
   at Microsoft.Win32.RegistryKey.SetValueCore(String name, Object value, RegistryValueKind valueKind)
   at Microsoft.Win32.RegistryKey.SetValue(String name, Object value, RegistryValueKind valueKind)
   at Microsoft.Win32.Registry.SetValue(String keyName, String valueName, Object value, RegistryValueKind valueKind)
   at PaintDotNet.SetupActions.RegistryUtil.SetValue(RegistryHive hive, String keyName, String valueName, Object value, Nullable`1 valueKind) in D:\src\pdn\src\PaintDotNet\Setup\RegistryUtil.cs:line 61
   at PaintDotNet.SetupActions.RegistryHandler.Register() in D:\src\pdn\src\PaintDotNet\Setup\RegistryHandler.cs:line 83
   at PaintDotNet.SetupActions.Program.MainImpl(String[] args) in D:\src\pdn\src\PaintDotNet\Setup\Program.cs:line 253
   at PaintDotNet.SetupActions.Program.Main2(String[] args) in D:\src\pdn\src\PaintDotNet\Setup\Program.cs:line 67
   at PaintDotNet.SetupActions.Program.Main(String[] args) in D:\src\pdn\src\PaintDotNet\Setup\Program.cs:line 28

 

It couldn't set the registry key, HKEY_CLASSES_ROOT\paint.net.1\shell\open\command\(Default)

 

But from the log, it looks like you were able to successfully install an hour later?

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...