Jump to content

plugins duplicating/


Recommended Posts

Another troubleshooting tip: rename the Effects folder so PDN can't find it. If the duplicates and the original plugins are gone when you reboot, then you know for sure both copies of the plugin reside in the Effects folder.

 

It might also pay to check the contents of all other folders in the installation directory.

Link to comment
Share on other sites

@Pixey Pointed out, yesterday, that I hadn't really fixed it.

So thought I'd explain what I did.

I uninstalled pdn 4.3.2. And after unchecking 'Automatic updates box' I installed 4.2.16.

Problem solved. No duplicates.

However I tried three times to update to 4.3.2.

Each time it went back to duplicating.

So at the moment, I am sticking to 4.2.16, works fine.

I don't know why it is effecting me and nobody else.

Maybe the techs can work it out.

Thank you everybody for your help.

Cheers.😉

Edited by Manc

manc4.png

Link to comment
Share on other sites

1 hour ago, Manc said:

I uninstalled pdn 4.3.2. And after unchecking 'Automatic updates box' I installed 4.2.16.

 

That's a long way from a fix.

 

From what I saw from Pixey's tooltip sceenshot, it seems pretty clear that either the PDN tooltip isn't working correctly, or your Effects folder contains a subfolder, also named Effects, which contains copies of the plugins. The second seems a lot more likely, and is easily fixed.

Link to comment
Share on other sites

17 minutes ago, MJW said:

or your Effects folder contains a subfolder, also named Effects, which contains copies of the plugins

 

Before he went back to 4.2.16 I checked that, and there were NO other Effects folders in there.  He did have another in "paint.netUserFiles" - but I deleted them.

 

As he's now using 4.2.16, and there are no longer any duplicates, one wonders why it's happening when he tries to download 4.2.3?

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

1 hour ago, Manc said:

I don't know why it is effecting me and nobody else.

 

Your are not the first one who has an additional folder in the Effects folder (i.e. to store unused plugins).

The support of sub folders in Effects is a new feature in 4.3.  Every upgrade of paint.net will show you the duplicates. This will not change so you should try to solve it now.

I would do the following.

 

1) Open the Effects folder

2) Select the 'View' tab at the top

3) Click 'Options'->'Change folder and search options'

4) Select the 'View' Tab in this dialog.

5) Select 'Show hidden files and folder'

6) Close the dialog with 'OK'

 

Hidden folders are now visible in the Effects folder.

Delete these folders. Probably the name is 'Effects'

 

or if nothing works

 

1) Rename the folder Effects to EffectsOld.

2) Create a new folder Effects.

3) Move all plugins from EffectsOld to Effects.

 

 

 

  • Like 1

midoras signature.gif

Link to comment
Share on other sites

15 minutes ago, Pixey said:

 

Before he went back to 4.2.16 I checked that, and there were NO other Effects folders in there.

 

Did you enable viewing hidden files? Though I don't know why the folder would be hidden, I also can't think of any reason the tooltip would say the plugin is in Effects\Effects\ unless there is a subfolder named Effects. I think there most likely is.

 

PRE-EDIT: I see as I typed this, midora also mentioned the hidden attribute. Also, I like midora's suggestion to create a new Effects folder, then copy over all the plugins. That will probably solve the problem without worrying about the exact cause.

Link to comment
Share on other sites

4 minutes ago, MJW said:

 

No, because he'd already changed back to 4.2.16 before this idea was posted.

 

I will offer to help him again, via Quick Assist, if he goes back to 4.2.3

 

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

29 minutes ago, MJW said:

Also, I like midora's suggestion to create a new Effects folder, then copy over all the plugins. That will probably solve the problem without worrying about the exact cause.

 

If that's tried, I suggest in the File Explorer:

 

Rename Effects EffectsOld.

Create a new Effects folder.

 

Set "View" to Detail.

Set "Sort by" to Type.

 

In the EffectsOld folder (original Effects folder):

Left click on the first DLL.

Left click with Shift held down on the last DLL. All the DLLs will be selected.

Right click and choose Copy.

 

In the new Effects folder:

Right click and choose Paste.

 

That should copy over the DLLs and nothing else.

Link to comment
Share on other sites

Many thanks @MJW and @midora for the tips.

 

I went back via Quick Assist, and @Manc went back to 4.3 - this time via File Explorer and I finally found the duplicated Effects folder, now deleted, and he now has no more duplicates 😃 Yay!

  • Like 2
  • Upvote 1

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...