Jump to content

Text comes out garbled


Recommended Posts

A random little problem I've had pop up from time to time. Must've been at least a couple of years at this point but I never bothered to make an account to ask about it until now. I tried looking it up but never found any results so I decided to make a thread of my own about it.

 

As you may see from the provided image, there is a small chance for the text to come out all garbled. The extent of it varies; sometimes, every word will be garbled up, other times only some words. It occurs when clicking, either on another area of the image or on a tool icon. It doesn't happen consistently. There are times when I will try to write something, the text will come out garbled and I'll re-type it - and it'll happen again. It also seems to re-occur on the same spot in an image; for example, I'll write something out, then move the text somewhere else, and it'll come out garbled once I click. I'll type it out again, and again move it to that part of the image, and it'll happen again. Or maybe it would've come out garbled even if I left it in the original spot, I don't know. 

Not really sure how to replicate it, either, it took a while for the underlined text to pop up. 

 

It's not really a huge problem but when it happens, it tends to happen a few times in a row, which can be annoying. Sorry if this has been asked about a million times before, it just seems like it's something that has been carried over across many versions of this, admittedly, very cool program which I have enjoyed using for many years.

Untitled.png

Link to comment
Share on other sites

That image is just a straight crop. Indeed, the text is Tahoma 8. I've never changed the resolution from 96.

So, you two are saying it's zoom related? I certainly spend most of the the time zoomed in , often A LOT higher than 100%. What's strange is that often times when the problem comes up, it'll only affect a specific part of the text, like there's an area on the image that is affected. I'll keep rewriting only part of the text and the same area will get the garbled up pixels.

 

Luckily, replicating the problem is super hard because it comes up quite rarely and goes away soon after. Again. it's a pretty minor problem, I just figured I may as well bring it up to see some expert opinions. If it means staying at 100% zoom, I guess I can bear a few artifacts once every few months. 

 

 

Link to comment
Share on other sites

You don't need to be at 100% zoom specifically, but at any multiple of it, e.g. 200% 300% 400% etc.

 

And just zoom however you want, and if you see the artifacts set the zoom to one of those levels to verify it's just a rendering artifact and then go back to what you're doing.

 

I say this is a just a "rendering artifact" because the canvas renderer can't always get tiles to line up perfectly and these types of things show up occasionally. The image itself is perfectly fine, it's just displaying a little incorrectly. Sometimes it's dependent on the GPU or its driver, i.o.w. you'll see this more/less based on your GPU and the GPU driver version you have installed.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

To be fair, if it was screenshotted outside of 100% zoom, I wouldn't have been able to compare fonts to match tahoma 8pt to it. Meaning this was screenshotted at 100%, so it's not a viewing artifact. I'm not really sure what it is.

But to Rick's point, if you upload the exact same file as a png (instead of a screenshot of how it displays for you) and let us look at it, that would rule out driver display issues too. I suspect something else is going on and it's neither zoom nor your GPU drivers.

Edited by NinthDesertDude

Untitled.png.28dedeebdce78c42589f24716981923f.png

Link to comment
Share on other sites

Alas, I didn't think to save the image. Thank you both for your help, I will keep this in mind for the next time I have this occur, and I'll try the multiples of 100% zoom view, as well as upload the full file.

 

Might take a while. It's a bit silly but replicating the problem is a lot harder than having it reoccur in a single session.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...