Jump to content

paint.net 4.3 alpha build 7881


Recommended Posts

This big thing for this update is that I was able to get @Ed Harvey's effect plugins to work! And that's basically it, but that's a really big win :) 

 

In order to get it working, the DLL is modified to fix up the code that doesn't work on .NET 5. There were two properties of type ContextMenu that had to be removed (they weren't being used), and some reflection against some fields in VisualStyleRenderer that were renamed. This was pretty easy with the use of Mono.Cecil.

 

To get this update, make sure you have "Also check for pre-release (beta) versions" enabled in Settings, and then click on the Check Now button. (Unfortunately alpha/beta releases are not currently available for the Microsoft Store version of the app).

image.png

Direct download links:

Changes since 4.3 alpha build 7879:

  • Fixed: EdHarvey's Effects now work as-is without the need to install an updated version (which is not yet available)

 

The complete list of changes so far for 4.3, as compared to 4.2.16:

  • New: The app has been migrated to .NET 5, and performance has been greatly improved as a result.
  • New: ARM64 is now natively supported
  • Installation is much faster now due to no longer needing the "Optimizing performance for your system" stage (NGEN has been replaced with ReadyToRun via crossgen).
  • Portable ZIPs are now officially available, utilizing self-contained deployment, and do not require the installation of .NET 5. You must manually update to newer versions of the app, however.
  • Improved performance of most effects and other compute-intensive tasks by about 20% on average, due to .NET 5's improved code generation
  • Improved: Many areas of the app have been optimized to use SIMD (SSE2/3/4.1, AVX2) on x86/x64
    • Drawing on an image with a large number of layers is faster
    • Drawing with the Gradient Tool's alpha mode is faster
    • Drawing with the Recolor tool is faster
    • Drawing with the Erase or Clone Stamp tool is faster when using a color whose alpha value is less than 255
    • Drawing with the Overwrite blend mode is faster
    • Drawing with the Shapes tool is faster, due to improved compositing performance
    • Drawing with a brush tool without antialiasing is faster
    • Tile compression has lower overhead due to being optimized for SSE2 and AVX2
    • Working with complex selections is faster
    • Many other optimizations all throughout the application and rendering engine
  • Improved: Selection antialiasing quality is now better by way of using a 4x4 super sampling filter instead of 3x3. The code has also been optimized to use SSSE3 on x86/x64.
  • Improved: Performance should be significantly better on systems without HyperThreading (by reserving 1 core for the UI), and also a bit better on systems with it (by utilizing more of the logical cores)
  • Improved: Effect and File Type plugins can now be organized into folders -- the plugin loader will recursively search for DLLs up to 1 folder deep
  • Fixed a bug in Polar Inversion that was causing hangs
  • Improved performance of Polar Inversion by 3x, due to the aforementioned bug fix (and a little bit is due to .NET 5)
  • Fixed: There were some issues with zooming in/out using the keyboard, where the anchoring (centering) point was not calculated correctly, causing the canvas to drift in the wrong direction.
  • Fixed a bug when saving with "Auto Detect" bit-depth that was causing fidelity loss on some images that already had 256 colors or less. This was reported here: https://forums.getpaint.net/topic/118401-images-already-with-256-or-fewer-colors-being-dithered-when-saved-with-palette/
  • Changed: A processor that supports SSSE3 (yes 3 S's) is now required for x86/x64 systems (previously only SSE2 was required). All CPUs released since about 2006 (e.g. Core 2 Duo) support this.
  • Known Issue: Due to crashing, GPU accelerated effects (Gaussian Blur, Motion Blur, Radial Blur) on ARM64 will actually use the CPU for rendering.
  • Updated the built-in AvifFileType plugin to v1.1.13.0 (courtesy of @null54). See the project's GitHub Releases page for more information.
  • Like 1
  • Thanks 1
  • Upvote 1

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

@Rick Brewster

One step forward, One step back.

I am following each new release of updated apps.

The plugin browser was working in the previous release.

It fails in this new one

@toe_head2001 did say it was a test release.

Spoiler

C:\Program Files\paint.net\Effects\PlugInData.dll, version 1.3.9.1

Name: Plugin Browser
Type: PlugInData.EffectPlugin
Version: 1.3.9.1
Author: © 2021 The Dwarf Horde
Copyright: Search for and Bookmark your favorite plugins
Website: https://forums.getpaint.net/topic/110458-the-plugin-browser/
This plugin is incompatible with this version of paint.net.
A mandatory update is available.


 

Signature2018.png

 

Link to comment
Share on other sites

It's great to see a new upcoming version is on its way. I've been using Paint.net for 3 decades now and will there be any new additional tools for example such as;

- additional lasso tools (polygonal and magnetic)

- brush tools (blur, sharpen, median and smudge)

 

to this upcoming version like other well-known free/commercial graphics applications.

Edited by John
missing sentence
Link to comment
Share on other sites

1 hour ago, gtopala said:

Portable ZIPs links for x86 and ARM64 are wrong (install instead of portable).

Thanks, I've fixed the links!

 

1 hour ago, gtopala said:

The https://www.getpaint.net/files/zip/test/paint.net.4.300.7881.3082.install.arm64.fdd.aot.zip installer fails on Surface Pro X.

 

 

I've got a Surface Pro X here and I'd like to try and reproduce what you're seeing. Can you tell me a bit more about what you have installed on your system, or rather what you had installed at the time of the error? Did you have any .NET 5, 6, or Core 3.1 installed? Was it x86, x64, and/or the arm64 versions? (Win11 arm64 can actually install all of them!) Did you end up getting it to work somehow, or are you stuck? (for example, maybe you installed .NET 5 manually, and then the PDN installer afterwards and it worked/failed?)

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

I was able to reproduce that error if I have only the x64 version of .NET 5.0.8 installed. @gtopala is that what you had?

 

Unfortunately there's a bit of a bug in .NET right now whereby both the x64 and arm64 versions will install to the same location and effectively clobber each other. If you have the x64 version installed, then you'll get the FailedHostfxrExports error. If you then install the arm64 version of .NET, e.g. from https://dotnet.microsoft.com/download/dotnet/5.0, it will overwrite the x64 version of .NET, and vice versa. This is fine if you don't have any x64 .NET apps you need to use, but not so great if you need both x64 and arm64 apps.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

I was also able to get the error to happen if I installed .NET 5.0.8 x64 and then .NET 5.0.8 arm64 (both Runtime and Desktop Runtime, due to a bug they had in their deployment of the installers where Desktop Runtime didn't also include the base Runtime package:https://github.com/dotnet/windowsdesktop/issues/1823 )

  • You're a Smart Cookie! 1

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

I just updated to 4.3 (a 4.300.7881.30820) and am experiencing trouble with the Gradient Tool set to transparency.

 

This:   Untitled.png

 

With Gradient set to transparency:  transparent-gradient-mode.png

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

Just a question: I am running PDN 4.3 7881 (the latest), and I have .Net version 4.8.4084.0. Do I need to install .Net 5 to benefit from all the latest tweaks and code in PDN 4.3?

 

Thanks,

 

Brian

 

Link to comment
Share on other sites

Also, I've just noticed that the Lasso Select Tool is missing its little image when you select it to cut out something - I hope that makes sense 😁

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

1 hour ago, Pixey said:

Also, I've just noticed that the Lasso Select Tool is missing its little image when you select it to cut out something - I hope that makes sense 😁

 

That's intentional. I changed the cursor graphic to the standard crosshair.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

OK, I will accept that. What I meant by the 'Regedit' remark was that Microsoft have a page where they show you which is the correct key to look for in RegEdit to determine the .Net version, and mine only showed 4.8. Sorry for any confusion

 

Brian

 

Link to comment
Share on other sites

So how do I create plugins with this new alpha build? Looking forward to having the latest C# features with the plugin Im creating. I get assembly reference conflicts with "WindowsBase.dll" where my plugin wants 5.0.0 and yours wants 4.6.0. 
EDIT:
I figured out how. See: 

 

Edited by xchellx
Link to comment
Share on other sites

On 7/30/2021 at 2:39 PM, Rick Brewster said:

Installation is much faster now due to no longer needing the "Optimizing performance for your system" stage (NGEN has been replaced with ReadyToRun via crossgen).

 

I'm really impressed with the installation speed!! 👍

  • Like 1
Link to comment
Share on other sites

One small observation, and I can't remember on previous version, I select Adjustments on main menu and since the list is as long/longer than the screen, that list will hide the Effects menu option. Note: this only an observation. (Easily removed by clicking on Adjustments again). I am continually amazed at the quality of this s/w. Edit: And amazed at the quality of the contributors)

 

Best

Hugh 👍

PDNADJ.png

Edited by Panchdara
Link to comment
Share on other sites

On 8/1/2021 at 1:29 PM, xchellx said:

So how do I create plugins with this new alpha build? Looking forward to having the latest C# features with the plugin Im creating. I get assembly reference conflicts with "WindowsBase.dll" where my plugin wants 5.0.0 and yours wants 4.6.0. 
EDIT:
I figured out how. See: 

 

 

If you're using a template, you'll need a new version of the template. It's not hard to convert .csproj files to the new "SDK-style project" format and update them for .NET 5, but it also helps to be well-versed in this area.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

hi,

 

I have three plugins - BBChart.dll, ImageDistortion.dll and ParallelLinesEffect.dll - which show as Plugin Errors in the new version. Any ideas?

 

Thank you,

 

Brian

 

Link to comment
Share on other sites

Hi @BDP

 BBChart.dll is a known issue. The author needs to update it.

To run the other plugins you need the OptionBasedLibrary v0.7.9 dll and dlc files included in the download.

Ensure they are placed in the paint.net/effects folder

Hope this helps :)

 

Signature2018.png

 

Link to comment
Share on other sites

Thank you. I thought I would re-download the plugin to make sure I had everything, but I couldn't get past the adverts for shoot 'em up games. I really distrust sites like that, so gave up

 

Brian

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...