Jump to content

Recommended Posts

Hello everyone, I am currently working on a texture pack for minecraft. I have done this several times, but this time the color keeps changing after i save the flie. I saved it as a .png. the first picture below is the picture i based it on. the picture at the very bottom is the result after saving. you can see that it is missing one colour. i tried editing it again but after saving again, it changes back. If anyone knows why this is happening, please tell me. It is getting exteremly frustrating.

 

p.s. this is the first time this is happening, it was perfectly fine for other texture packs. and the same thing happens for other blocks, too.

ara-rasmussen-grass-side2-copy.jpg

Capture.PNG.dad80352cd82245e326949a8e02f5b12.PNG

Edited by oswin wong
Link to post
Share on other sites

Could you tell us which color is missing?  As the images are different sizes, it's hard to tell.  I've checked about 10 colors between the images, and they have have matched the same.

 

(Beaten by @BoltBait 😁)

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to post
Share on other sites
25 minutes ago, Pixey said:

Could you tell us which color is missing?  As the images are different sizes, it's hard to tell.  I've checked about 10 colors between the images, and they have have matched the same.

 

(Beaten by @BoltBait 😁)

It was in the brown part of the picture and the colour was #392a25. its the colour in between (not the darkest nor lightest one)

Link to post
Share on other sites

There's still a bug in 4.2.13 when saving at 4-bit color depth. Auto-detect will use 4-bit if it figures out that the image has 16 or fewer unique colors.

 

In that case, either select 8-bit, or install the beta for 4.2.14 which has a fix: 

 

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...