Sign in to follow this  
Thundercraft

DDS and making alpha channel Black

Recommended Posts

I'm currently working on a mod for a game. And I'm trying to modify a .DDS "diffuse" texture. I found a tutorial on how to create or modify textures for the game. However, it was written under the assumption that the reader is using Photoshop.


I was able to modify the texture just fine. However, in-game, it looks very glossy. This is not intended as it is supposed to be a texture for clothes. Finding and reading the tutorial I mentioned explains that to make a texture appear glossy in-game, the alpha channel must be white. And to make a texture appear matte in-game (which is what I need), the alpha channel must be black.

 

Thing is, no matter how I select the options for saving in the .DDS format, it always appears glossy. And I do not find an option to change whether white or black is used as transparent for the alpha channel - either in the menu for saving in the .DDS format or anywhere else.

 

Am I missing something obvious? Is it even possible to use black for the alpha channel in Paint.Net? Is there a plugin to do this?

 

Edit: I got a reply from the author of the tutorial when I asked for clarification:

In PS, there's an option to show separate channel of RGBA. Each channel is in grayscale and I can manipulate each channel separately.

 

I still don't get it. But then, I haven't used PhotoShop in a long, long time.

Edited by Thundercraft
New information.

Share this post


Link to post
Share on other sites

Nevermind... The tutorial I mentioned was just very difficult to understand.

 

I think the author meant that one needed to set the alpha to transparent or near transparent for a texture to appear matte instead of reflective.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this