Sign in to follow this  
NotaBobR.

Not enough memory to open a pdn

Recommended Posts

Hello guys,

 

i tried to open a older .pdn (from 2013 i think) with ~29mb filesize. I know that this file has a lot of layers and a very, very high resolution, but without much informations on nearly all layers, except the base layer.

 

Today i tried to open the file with pdn 4.2.8, but it wasnt possible anymore because of "not enough memory". Ive created the file on the exact same computer (which is a i7 2800k with 16GB of ram and win7 x64 on it. only a 1080ti was added in 2018)

 

Task-Manager told me, that there is over 11gb of free/available ram space. Even the installed OS is the same, but of course with more security updateds, higher pdn version and so one. Im sure, that it was possible to open the file in 2013 with less free/available ram space because i had VMWare workstation running back then while i was editing the file.

 

So, what could be the reason? Are there any changes since the 2013 pdn version which might have a higher ram consumption?

 

 

Share this post


Link to post
Share on other sites

I found reference to an "Out of memory" sticky somewhere on this forum but I could not find it.

 

However the replies, including from RB, to other posts on similar matters suggests that indeed is just the problem - you've run out of memory due to the image's file size.

 

I'm wondering what would happen if you simply reduced your monitor's resolution. It may also explain why in the past you could open it with PDN if you were using another monitor with a significantly lower resolution.

 

HyReZ's suggestion would effectively do the same thing as Safe Mode uses 800×600 by default.

 

 

 

 

Edited by IHaveNoName

Share this post


Link to post
Share on other sites

Thanks for all your answers.

 

I was able to open it with v3.5.11 (uninstalled 4.2.8, installed 3.5.11 withou a reboot)  but i did some further investigations because i noticed, that the size in memory is only 8.837.044K with 3.5.11, which is far less than over 11GB of free/avaiable memory.

 

By the way: The used memory size with 4.2.8 is only 7.433.952K.

 

First of all, let me say that because of speed reasons, i do not use a pagefile, so there is a hard limit of 16GB ram-memory if pagefile is deactivated. I noticed, that 3.5.11 starts to opening the file no mather if there is enough free memory or not. If there is enough memory, everything is fine and i can open and edit the file. If there is not enough memory, the pc is running out of memory while 3.5.11 is loading the file and pdn and a bunch of other programms stop working. So, activating pagefile with enough space is a workaround for 3.5.11 and 4.2.8., but i would not say that its a solution at all, because 4.2.8 should also be able to open the file if there is significant more memory available than the file takes.

 

So, it seems that 4.2.8 has some mechanism implemented, which compares the expected size in memory vs. the free memory size before it starts to load the picturedata, because the error mesage "not enough memory" appears immediately when i try to open the file. Is this correct?

 

If so, in general its good, that there is such a check, but if there is 11.3GB memory available and the file takes only 7.5GB in memory, this check could possibly get some improvements. In my opinion, the best method would be, if you guys could add a "sizeinmemory" flag inside of the pdn-format which is written if you save the file and checked if you try to load it.

 

 

 

 

 

 

Edited by NotaBobR.

Share this post


Link to post
Share on other sites

Also running in the 'Safe Mode' reduces the amount of processes running in the background.
My computer also has 16 GB of RAM, and 2GB is shared with the on-board graphics processor, yet I can load files larger than 30MB into Paint.NET.
I am running Windows 10 Home 64bit v 1909 build 18363.535

 

BTW:
Check to see if the file is fragmented.
Some defrag apps such as UltraDefrag will let you defrag a single file.

  • Like 1

Share this post


Link to post
Share on other sites

If you send me the PDN file I can look into it, but it's worth pointing out that turning off the pagefile doesn't actually help performance. That's just one of those "tweaker" superstitions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this