Sign in to follow this  
Rick Brewster

paint.net 4.2.6 alpha build 7256

Recommended Posts

This should fix the 2 big crashes that people have been reporting.

 

To get this update, make sure you have "Also check for pre-release (beta) versions" enabled in Settings, and then click on the Check Now button. (Unfortunately alpha/beta releases are not currently available for the Microsoft Store version of the app.

image.png

You can also download directly: https://github.com/paintdotnet/release/releases/download/4.206.7256.6914/paint.net.4.206.7256.6914.install.zip

 

Changes since 4.2.6 alpha build 7254:

 

  • Fixed the crash when using pointer devices for drawing. This also affected mouse drawing when the app's DPI didn't match the monitor's DPI.
  • Fixed the crash when saving an image and dismissing the Save Configuration dialog before it could draw anything (e.g. by pressing Enter)
  • Like 2

Share this post


Link to post
Share on other sites

The DPI crash has been resolved, but there are some remaining issues:

There are duplicate lines when drawing free-hand in my secondary screen, both when using pencil and when using brush (see attachment - strokes are continuous).

I only using a mouse - no other pointer devices.

Main monitor: 1920×1080 px, Secondary monitor: 1440×900 px.

 

Another (minor) issue I have had (but it happened in previous versions) is the layers popup not following the main window when moving it between monitors via Windows+Shift+Arrows. Colors and tools panel do move with the rest of the window.

 

image.thumb.png.434f93522077b5bb0eaa9cc54d10c8fc.png

Share this post


Link to post
Share on other sites
37 minutes ago, ivaniesta141 said:

Another (minor) issue I have had (but it happened in previous versions) is the layers popup not following the main window when moving it between monitors via Windows+Shift+Arrows. Colors and tools panel do move with the rest of the window.


It will only follow if it is docked. 

Share this post


Link to post
Share on other sites

It seems the Updater can't connect to GitHub on Windows 7.

pdnSSL.png

 

I've tested this on two Windows 7 installations, and both failed.  No update issues on Windows 10.

 

GitHub.com only allows TLS v1.2 and v1.3 connections.  Windows 7 does support v1.2, but it's off by default: https://docs.microsoft.com/en-us/dotnet/framework/network-programming/tls#support-for-tls-12

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Quote

 What are the DPI settings for each monitor?

 

According to Windows 10 settings, 125% on my main monitor (120 dpi), 100% on my secondary one (96 dpi).

I don't remember having any issue with previous versions, but I will try rolling back tomorrow to check again. 

Share this post


Link to post
Share on other sites
36 minutes ago, toe_head2001 said:

It seems the Updater can't connect to GitHub on Windows 7.

pdnSSL.png

 

I've tested this on two Windows 7 installations, and both failed.  No update issues on Windows 10.

 

GitHub.com only allows TLS v1.2 and v1.3 connections.  Windows 7 does support v1.2, but it's off by default: https://docs.microsoft.com/en-us/dotnet/framework/network-programming/tls#support-for-tls-12

 

Oh that's good to know 😬

  • Like 1

Share this post


Link to post
Share on other sites

Just checked back with 4.2.5 and the issue persists. Also drawing on my second monitor when the window is between screens (but in my main screen) just makes paint.net draw weird lines (see attachment, right side). This also happens when the screen is half-way on both screens, active on the second one and drawing on my main screen (left side). Most likely a bug when handling dpi.

 

image.png.6282b5c4a53cb2629185ad347924b877.png

  • Upvote 1

Share this post


Link to post
Share on other sites

I'll make sure the next alpha build is available for Windows 7, @Seerose.

 

Some side commentary though, please upgrade to Windows 10. This is very important, as Microsoft's support of it is ending in a few months and I'm going to have to drop support at some point as well ("support" meaning "it will no longer work", btw). You can probably still upgrade for free, see here: https://forums.getpaint.net/topic/114255-reminder-please-upgrade-to-win10-microsoft-ending-win7-support-january-2020/?do=findComment&comment=564624

 

 

Using github for the ZIP file distribution is going to be very important when Paint.NET is ported to .NET Core next year because the ZIP file size is going to increase to at least 50MB (currently it's just under 10MB). My current hosting plan isn't really equipped for that.

 

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, toe_head2001 said:

It seems the Updater can't connect to GitHub on Windows 7.

pdnSSL.png

 

I've tested this on two Windows 7 installations, and both failed.  No update issues on Windows 10.

 

GitHub.com only allows TLS v1.2 and v1.3 connections.  Windows 7 does support v1.2, but it's off by default: https://docs.microsoft.com/en-us/dotnet/framework/network-programming/tls#support-for-tls-12


Hi!
I'm using Windows 10 Pro v1903 Build 18362.449 OS. This problem also appears on my computer. paint.net can detect the update but cannot download and install it, this problem is the case for the last two or three versions; therefore, I download and install it in both cases manually.

Edited by yaschir

Share this post


Link to post
Share on other sites
4 hours ago, Rick Brewster said:

huh! That's not good :( Thanks for reporting it @yaschir

 

To be clear, this has only affected the 4.2.6 builds? 

You're welcome. I'll download v4.2.4&4.2.5 and check for the newest.

Edited by yaschir

Share this post


Link to post
Share on other sites
4 hours ago, Rick Brewster said:

huh! That's not good :( Thanks for reporting it @yaschir

 

To be clear, this has only affected the 4.2.6 builds? 

A few days ago, it was not possible to upgrade automatically (to v4.2.6 beta X from v4.2.5 final and to v4.2.6 beta new from v4.2.6 beta old) due to this error. The good news is, I tested all of them and observed that this error was corrected🥰. It can be upgraded to the latest final and beta, including previous final and beta versions. Thank you so much.

Edited by yaschir

Share this post


Link to post
Share on other sites
9 hours ago, ivaniesta141 said:

Just checked back with 4.2.5 and the issue persists. Also drawing on my second monitor when the window is between screens (but in my main screen) just makes paint.net draw weird lines (see attachment, right side). This also happens when the screen is half-way on both screens, active on the second one and drawing on my main screen (left side). Most likely a bug when handling dpi.

 

image.png.6282b5c4a53cb2629185ad347924b877.png

 

Okay, I can reproduce this. There were some similar problems in 4.2.5 and before as well. GetMouseMovePointsEx is a really damn difficult to work with API.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this