Recommended Posts

after latest update, freezes on saving, cannot get out have to use task manager to exit, this is random, not everytime. Can we not have the option to keep the version we are on, why enforce updates and cause these problems or have an option to revert if problems encountered

Share this post


Link to post
Share on other sites

Howdy, @carpless,

Which image format are you saving in? Or do you have this issue with every format? Are you saving images large dimensions and/or many layers?

 

 

No one is forcing you to update paint.net. You can decline the updates when prompted. You can also disable update checking in paint.net's Settings.

Share this post


Link to post
Share on other sites

This is unlikely to be caused by anything in the newest version.

 

Usually hanging like this happens because you're trying to access a network share that's no longer available (or the server is flakey) .... or you have some shell extensions installed that are causing the hang.

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, toe_head2001 said:

Howdy, @carpless,

Which image format are you saving in? Or do you have this issue with every format? Are you saving images large dimensions and/or many layers?

 

 

No one is forcing you to update paint.net. You can decline the updates when prompted. You can also disable update checking in paint.net's Settings.

its on .dds  I do skinning for gtav, never had a problem with multiple layers before, and only 2 layers on this occasion... just re-loaded v4.1.1 and turned off updates to see if it happens again, if it does it'll be the image

Share this post


Link to post
Share on other sites
19 minutes ago, toe_head2001 said:

Howdy, @carpless,

Which image format are you saving in? Or do you have this issue with every format? Are you saving images large dimensions and/or many layers?

 

 

No one is forcing you to update paint.net. You can decline the updates when prompted. You can also disable update checking in paint.net's Settings.

just tried exact save with version 4.1.1 and no problems at all. will continue with this version until I've finished project and then update and report back if necessary. 

Share this post


Link to post
Share on other sites
18 minutes ago, carpless said:

ok will try this version for rest of project and report back any problems thx

Nope sorry moved to other images and still .dds, on saving I had a brief under 1 second message no responding on the top of save box. then it saved. On closing and then clicking save it froze again, but no pinging when clicking mouse to get out of it... 

Share this post


Link to post
Share on other sites

Also which version of Paint.NET is giving you trouble? 4.2.1 or 4.2.2? I need more information if there's actually a problem. If there's actually a problem then it'd be helpful to know how to fix it so others won't go through the same hassle.

 

If it's 4.2.2 and you're working with DDS images, try going into Settings and un-check "Enable hardware acceleration".

Share this post


Link to post
Share on other sites
6 minutes ago, Rick Brewster said:

Also which version of Paint.NET is giving you trouble? 4.2.1 or 4.2.2? I need more information if there's actually a problem. If there's actually a problem then it'd be helpful to know how to fix it so others won't go through the same hassle.

 

If it's 4.2.2 and you're working with DDS images, try going into Settings and un-check "Enable hardware acceleration".

ok.... just FYI  4.1.1 is so fast, something to look at?  ok, my original problem was with 4.2.1  then My second report was on 4.2.2  will try with hardware acceleration turned off for you. 

Share this post


Link to post
Share on other sites
5 minutes ago, carpless said:

ok.... just FYI  4.1.1 is so fast, something to look at?  ok, my original problem was with 4.2.1  then My second report was on 4.2.2  will try with hardware acceleration turned off for you. 

just loaded 4.2.2 plugin erros show, Ddsfiletype.dll  also showing comments that this is now built into paint.net …. mean anything to you? 

Share this post


Link to post
Share on other sites
21 minutes ago, carpless said:

ok.... just FYI  4.1.1 is so fast, something to look at?  ok, my original problem was with 4.2.1  then My second report was on 4.2.2  will try with hardware acceleration turned off for you. 

Turned off hardware acceleration seems to be working and its fast too … FYI my G{U is  GTX960 2GB 

 

Share this post


Link to post
Share on other sites

For the crash you're seeing in 4.2, that was fixed in 4.2.1. ("System.OperationCanceledException: The operation was canceled")

 

For the crash you're seeing in 4.2.2, that is likely caused by a crashing Effect or Adjustment plugin. Does that sound right? Plugins will have the little green puzzle piece next to them in the menu. ("System.NullReferenceException: Object reference not set to an instance of an object.")

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, carpless said:

just loaded 4.2.2 plugin erros show, Ddsfiletype.dll  also showing comments that this is now built into paint.net …. mean anything to you? 

 

It means exactly what it says ...  that the plugin is now built-in to Paint.NET. 


It's not really an error, more just telling you that the plugin files you installed aren't needed anymore.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.