MickoZ

Couldn't register to the forum

Recommended Posts

Hi, of course I am registered now, so I found a way.  I am sorry if I post this related to the software, but I don't know what other forum to post it to.

I tried to "register/sign up" by clicking the "sign up" button on top-right of this site.  There is a popup that appeared, and each time I tried, it said:

Security Check

You did not pass the security check. Please try again.
 
I was honestly beginning to think that I am way too dumb to be able to answer ALL the questions that were asked.  I even tried to answer "spammer" instead of "dog" to which's one life is more important.  I was going nuts.  I felt stupid.  I felt like my lack of native English speaking skills probably entered in the equation.  But, hey... I tried another way after I googled to see if I was alone that was that dumb.  I found the link https://forums.getpaint.net/register/ and I used it, I swear, I typed the same answer to the security question (and there was as a bonus a nice puzzle to do in that one, not in the popup, so there was now two security challenge).  And it passed.
 
So maybe I was not that dumb and that this "Sign Up" popup has some issues.  Just saying.  Please forward to the high authority who is responsible for this forum.
 
Thanks

P.S., It seems like I cannot edit my "display name" after register here.  While I have no problem using my "Real Name", I was pondering of using my usual internet nickname after I saw people use their for their profile.  Can we change this?  If no, why?
 
Edited by Michael Muryn
Added a P.S about not being able to change my display name

Share this post


Link to post
Share on other sites

I don't know if the last two posts was joke or the last was a joke related to the one previously. 😉
But what I reported is that in one use case... there was no puzzle, and if I answered the expected answer, it was not allowing me to sign-up (try it yourself); maybe it expect a puzzle answer too and none show up.  Then when passing through the /register URL as I said... then I got the same question + the puzzle (which was not hard for me :P) and it passed.  I answered the exact same answer on both, but one would always reject all my answers, while the other one worked the first time!

 

P.S., I just re-tested in a private-fresh-browsing-session, same result for validation that reject expected answers no matter what you input when passing through the top-right link when visiting the forum.

Share this post


Link to post
Share on other sites
1 minute ago, MickoZ said:

or the last was a joke related to the one previously.

 

My post was absolutely a joke in response to the previous post, and completely unrelated to your issue.

 

2 minutes ago, MickoZ said:

P.S., I just re-tested in a private-fresh-browsing-session, same result for validation that reject expected answers no matter what you input when passing through the top-right link when visiting the forum.

 

Ok, but this is still very anecdotal.

Are you able to do some proper debugging with the development tools built into most browsers? (I'm not sure what your level of technical knowledge is)

 

Share this post


Link to post
Share on other sites
22 hours ago, toe_head2001 said:

Ok, but this is still very anecdotal.

Are you able to do some proper debugging with the development tools built into most browsers? (I'm not sure what your level of technical knowledge is)

 

I can look and debug if you ask me to or want me to look at it (i.e., I'm a software developer and mainly have done Web development, I'm at ease).  I use Chrome BTW... you can probably test it yourself quickly to see if you notice the same behavior as me... just try to answer the security question in a fresh session (I use private session to do this quickly), I would guess you will hit the same issues as me when using the "Sign Up" button on top of the forum, but no issue when using the /register URL directly (unless Invision fixed something between my message and when you test it!).

P.S., I kept a tab of this forum open and saw the notification.  While I receive notifications for private message, I do not receive notifications for the forum post replies even if I enabled "Notify me of replies" from the start... weird.

Share this post


Link to post
Share on other sites

Update: I just re-tested in a fresh session and this time, the puzzle is showing up and I can answer the security question too without having an error even when providing the expected answer.  So I would say the issue is probably fixed now.  I was not seeing the puzzle in that context the two other days I tested it (but I was seeing the puzzle when using /register).

Share this post


Link to post
Share on other sites

@MickoZ it has been known that we have these visit us from time-to-time Gremlin-2.png

 

So glad you managed to sort it out in the end and that you got your User Name :)

  • Like 1

Share this post


Link to post
Share on other sites

Hello; I just signed up as well and ran into the same problem (I couldn't get past the 'secuity check' part of the registration page)
I googled 'you did not pass the security check' and found this post.
I tried the OP's suggestion of using the alternate link to register, and that worked.
However, my case was different because NOTHING showed up under 'security' when I tried to register on the original page/address. Since I had never seen the registration page prior to this, I had no idea that anything should of been accompanying the "security check" section of the registration page.  I assumed that the security check it was referring to would of been the question directly above that (I saw either a question about 'how many hours between' or 'whos life has more value'...  answering each one, whether correctly or incorrectly failed to allow my registration to go through...)
It was only after using the supplied link that the OP offered was I them able to see that there should of actually been a jigsaw puzzle like security check.  I am only posting this so if possibly anyone else stumbles across this whilst having troubles registering that it might help them out.  Thank you, and glad to be a new member here on forums! :)
 FWIW, here is what I saw on the first page where I was unable to register:
rdgiiM.png

Edited by kbishop94

Share this post


Link to post
Share on other sites

(translated with the help of the G ** gle translator)

Hi,

New in this forum today, I've seen a security barrier like this for the first time. But despite my poor English skills, I could easily understand and overcome this barrier.

(off-topic: I love "Idiocracy", but I only know the German dubbed version.)

Kind regards
,

MC Painter

Edited by MC Painter

Share this post


Link to post
Share on other sites

Hey @MickoZ, thanks for this thread, you really helped a brother out!

I was really this close to loose my sanity, for realz.

Registered through the proper link, and now it worked, I'm finally in!

It seems the puzzle won't load if you get to the registration through a thread.

Anyways, nice to finally be a part of this amazing forum.

 

Cheers! 🖖

/ Gew

 

Share this post


Link to post
Share on other sites

I could not register with the original link, kept getting the security rejection, even though I am, like, totally smart and stuff.  Managed to register at the alternative link.  There are probably a lot of people failing at that point and giving up.  Fixing this would be a good thing, probably.

Share this post


Link to post
Share on other sites
13 minutes ago, Hiblet said:

I could not register with the original link, kept getting the security rejection, even though I am, like, totally smart and stuff.  Managed to register at the alternative link.

 

When the registration was failing, was the KeyCAPTCHA Jigsaw Puzzle visible/functional?

Share this post


Link to post
Share on other sites
5 minutes ago, Hiblet said:

The failing attempt had no jigsaw puzzle

 

Yeah, that's why it failed. I'm pretty sure it's a bug with the forum software the website uses.

Share this post


Link to post
Share on other sites

OK, cool.  Maybe the site can have a link to the working alternative sign-up page?  I tried quite a few times, thinking I was getting the riddle answer wrong, trying alternative answers.  Good luck with getting a fix going, and thanks for the help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.