Recommended Posts

I've used Paint.net nearly every day for quite a while, with no problems whatsoever...a happy camper. Then, 4 days ago, I began to encounter a "save error" when trying to save files; it only happens occasionally, with no discernible pattern.

When it happens, I get the "Save Configuration" box, which, at the top, says, "Preview, file size (error)

And, I get a smaller box with "There was an error while saving the file"

The night before, I'd been using Paint.net just before going to bed, so, this error quite literally popped up overnight. I was using the latest version; I saw a similar problem posted in this forum with the suggestion that the OP there try installing the Beta version, so, I've also tried that, with the same results.

I'm only doing very basic touch-up work on these images...no layering, no added text or anything else...my version of Windows 7 Home Premium is up-to-date...and, I should also mention that my other graphics-editor, Irfan-View, modifies and saves these images with no problem...

Here's the "Details" 

 

Application version: paint.net 4.2.1 (β 4.201.7152.40366)

PaintDotNet.Imaging.PropertyNotFoundException (0x88982F40): D:\src\pdn\src\SystemLayer.Native\Imaging\WICBitmapFrameEncode.cpp (260) : hr = m_pBitmapFrameEncode->WriteSource( spBitmapSource, rect.HasValue ? &NativeConversions::ToWICRect(rect.Value) : 0);
   at PaintDotNet.SystemLayer.Native.x86.NativeUtilities.ThrowOnErrorImpl(Int32 hr, SByte* szHr, IUnknown* pFxErrorInfo)
   at PaintDotNet.SystemLayer.Native.x86.Imaging.WICBitmapFrameEncode.WriteSource(IBitmapSource bitmapSource, Nullable`1 rect)
   at PaintDotNet.Data.WicFileTypeHelpers.Encode(IBitmapSource source, Metadata metadata, Vector2Double dpi, Stream output, ContainerFormat containerFormat, Nullable`1 requiredVendor, IEnumerable`1 encoderOptions, MetadataTranscoder metadataTranscoder, ProgressEventHandler progressCallback, Object progressCallbackSender, Double progressPercentStart) in D:\src\pdn\src\PaintDotNet\Data\WicFileTypeHelpers.cs:line 443
   at PaintDotNet.Data.WicFileTypeHelpers.Save(Document document, Surface flattenedSurface, Stream output, ContainerFormat containerFormat, Nullable`1 requiredVendor, MetadataTranscoder metadataTranscoder, IEnumerable`1 encoderOptions, SavableBitDepths bitDepth, Int32 ditherLevelFor8bpp, ProgressEventHandler progressCallback, Object progressCallbackSender) in D:\src\pdn\src\PaintDotNet\Data\WicFileTypeHelpers.cs:line 321
   at PaintDotNet.Data.JpegFileType.OnSaveT(Document input, Stream output, PropertyBasedSaveConfigToken token, Surface scratchSurface, ProgressEventHandler progressCallback) in D:\src\pdn\src\PaintDotNet\Data\JpegFileType.cs:line 128
   at PaintDotNet.FileType`2.OnSave(Document input, Stream output, SaveConfigToken token, Surface scratchSurface, ProgressEventHandler callback) in D:\src\pdn\src\Data\FileType`2.cs:line 39
   at PaintDotNet.FileType.Save(Document input, Stream output, SaveConfigToken token, Surface scratchSurface, ProgressEventHandler callback, Boolean rememberToken) in D:\src\pdn\src\Data\FileType.cs:line 276
   at PaintDotNet.Dialogs.SaveConfigDialog.<>c__DisplayClass48_0.<UpdatePreviewAsync>b__0() in D:\src\pdn\src\PaintDotNet\Dialogs\SaveConfigDialog.cs:line 596
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
   at PaintDotNet.Dialogs.SaveConfigDialog.<UpdatePreviewAsync>d__48.MoveNext() in D:\src\pdn\src\PaintDotNet\Dialogs\SaveConfigDialog.cs:line 623

Share this post


Link to post
Share on other sites

When saving as JPG, what options are you using?

 

JpgOptions.png

Share this post


Link to post
Share on other sites

Does this happen when saving any image? For instance, what happens if you start up Paint.NET and try to save the default/blank image?

 

If that works, then maybe something's "bad" * in one of the images you're working on. If that's the case then it would help if you send me one of the images (just reply here and attach the image).

 

* ("Bad" in the sense that Windows doesn't like it... not your fault!)

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.