Stylianius1

Why does this error keep appearing when I try to open some files from the same folder?

Recommended Posts

This error (which is in Portuguese but I can roughly translate to English as "An unspecified error has happened opening the file") keeps appearing when I try to open a few files from the same folder.

I've been editing a Minecraft resource pack and all of the files opened without any problem, but after closing a file I've edited and trying to open it again, this error kept appearing. Then I tried other files I've edited in the same folder and none of them opened. I tried opening unedited files from the same folder and all of them opened without any problem. Then, I started opening other files I had in other folders from my PC and all of them also opened. It seems like ONLY the edited files from that folder can't open. What exactly is the problem and how can I solve it?

 

ERUERO.thumb.png.0e7f323e34b5aa4a387d33928c5687dd.png

 

Application version: paint.net v4.2

PaintDotNet.Imaging.ComponentNotFoundException (0x88982F50): D:\src\pdn\src\SystemLayer.Native\Imaging\WICImagingFactory.cpp (903) : hr = m_pImagingFactory->CreateDecoderFromStream( spStream, preferredVendor.HasValue ? &NativeConversions::ToNative(preferredVendor.Value.Guid) : 0, static_cast<WICDecodeOptions>(metadataOptions), &spDecoder);
   em PaintDotNet.Interop.InteropErrorInfo.ThrowIfError() em D:\src\pdn\src\Base\Interop\InteropErrorInfo.cs:line 98
   em PaintDotNet.SystemLayer.Native.x64.NativeUtilities.ThrowOnErrorImpl(Int32 hr, SByte* szHr, IUnknown* pFxErrorInfo)
   em PaintDotNet.SystemLayer.Native.x64.Imaging.WICImagingFactory.CreateDecoderFromStream(Stream stream, BitmapDecodeOptions metadataOptions, Nullable`1 containerFormat, Nullable`1 preferredVendor)
   em PaintDotNet.Data.WicFileTypeHelpers.Load(Stream input, Nullable`1 forcedContainerFormat, Nullable`1 preferredVendor, MetadataTranscoder metadataTranscoder) em D:\src\pdn\src\PaintDotNet\Data\WicFileTypeHelpers.cs:line 61
   em PaintDotNet.Data.PngFileType.OnLoad(Stream input) em D:\src\pdn\src\PaintDotNet\Data\PngFileType.cs:line 137
   em PaintDotNet.FileType.Load(Stream input) em D:\src\pdn\src\Data\FileType.cs:line 482
   em PaintDotNet.Functional.Func.Eval[T1,TRet](Func`2 f, T1 arg1) em D:\src\pdn\src\Base\Functional\Func.cs:line 158

Share this post


Link to post
Share on other sites

So long as the files are not objectionable - would it be possible to upload an original file and a saved version of the same thing?

Share this post


Link to post
Share on other sites

Maybe you saved a PDN as a PNG by accident? Pretty common mistake. Rename the .PNG to .PDN and it just might work.

Share this post


Link to post
Share on other sites

Might be that ^ but it is not the usual error message you see when it happens - unless it has been changed recently PDN usually reports a format exception and/or that the image is not a valid PDN document.

 

If RB's advice does not work I'd create a new clean, default folder somewhere else and try copying one of the edited pictures you can not now open into that then see if you can open that copy in PDN.

 

Should that not work, using the same new folder, try editing a copy of one of the unedited pictures you have as before but then saving it to that new folder rather than the original one and see whether that repeats the problem.

 

Maybe way off the mark but I'm thinking it might be a folder properties issue (not sure what) which is being applied when you save a PDN image file to that specific original folder. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.