Sign in to follow this  
AsgardTM

Colour Changing

Recommended Posts

Hello again !

After the last beta update paint.net is acting very weird ! For some reason the colors change and fading

For example black become red, white slowly become gray and so on. Is very important for me to fix this because I loose a lot of details..

Thanx.

 

Share this post


Link to post
Share on other sites
10 minutes ago, AsgardTM said:

white slowly become gray and so on

 

You mean the change of color happens gradually over time?

 

Otherwise, it might just be the Embedded Color Profile being applied when the image is initially opened. More info here:

https://forums.getpaint.net/topic/114612-paintnet-42-beta-build-7121/?do=findComment&comment=559855

Edited by toe_head2001

Share this post


Link to post
Share on other sites

Well that's not supposed to happen. The color profile should be purged after it's been applied that initial time.

 

Can you share an example image that is having this issue? So we can open and save it many times, and see what's going on.

Share this post


Link to post
Share on other sites
1 hour ago, AsgardTM said:

Hello again !

After the last beta update paint.net is acting very weird ! For some reason the colors change and fading

For example black become red, white slowly become gray and so on. Is very important for me to fix this because I loose a lot of details..

Thanx.

 

 

Any chance you are saving your drawings in JPG format?

Share this post


Link to post
Share on other sites

Sorry for late reply, i'm from Europe so from time to time I need to sleep :)

The image format is TIF and are big drawings 60K pixels and 300 to 600 DPI.

I will try to put some screen shoots:

http://prntscr.com/oae7u2

http://prntscr.com/oaebzj

 

In the first Black is becoming red which is the drawing I worked for the last 3 days and now is ruined because I use strictly color codes for all the lines.

In the second screen shoots is a backup file which is also starting to change because I already opened once or twice with paint.net

 

 

Edit: I made some more screenshots

 

http://prntscr.com/oaing9

This drawing is made before the last beta update and you can see how the black is already changed, but just a little...

 

http://prntscr.com/oailxj

In this one you can see how baddly the colors are faded, although are the same used like in the first screenshoot

 

Edited by AsgardTM

Share this post


Link to post
Share on other sites

I do not fully understand the explanations I've read but a little research indicates this is a known general image display 'problem' and probably nothing to do with PDN except in so far it apparently only supports RGB.

 

Apparently it is all to do with the colour mode/colour space (RGB /sRGB) and. as toe-head2001 said,

profile being used. Monitor colour calibration can also be involved. If there is a mismatch when the image is saved and re-opened the colour shifts a small amount. At least that is what I think it means.

 

https://petapixel.com/2009/09/17/why-you-should-probably-use-srgb/

 

Just Google "TIFF file color change" and you'll find plenty more information on such matters including old threads from this forum.

 

If somebody here can explain it in really simple terms it would be helpful and appreciated. 

Edited by IHaveNoName

Share this post


Link to post
Share on other sites

I know what you are saying, but here is not the case. I didn't heard that black will become red after a wile. Maybe just a little more grayish, but not red !!!

And why this didn't happen first ? Why after the developer change something with the software which is about colors ?!!!

I use paint.net for ... I don't remember really, I think for the beginning and I never  saw doing something like this.

Share this post


Link to post
Share on other sites

Have you tried opening the original file in another graphic program like IrfanView to see if the colour shift you're seeing repeats?

 

I hope it is OK to mention that other program here because, in this specific case, it does include particular Colour Management control options so that may help identify if this is a colour space issue or something else.

 

 

Share this post


Link to post
Share on other sites

Did you start these with Paint.NET or did they originally come from other software?

 

I really do need the images themselves so that I can inspect them to see if they have a color profile, or to see if something else is going on. Otherwise I literally cannot attempt to fix this. Screenshots are not enough.

Share this post


Link to post
Share on other sites

The drawings are 70 or more years old, and are scanned at 100% and I need the scale intact, because not all the data are write on them. Very few plans remained (about 400 from 7000 or so) the size factor is very important. The copies are TIF with this embedded color code:   kip129-g20-comp.icm

I can't give the file to you because are kinda secrets. It's a fighter plane and no one exist anymore, so I can't share the plans. It's already to much I posted the screenshots, sorry.

 

Edit: grammar corrections...

Edited by AsgardTM

Share this post


Link to post
Share on other sites

Okay I managed to transcode a PNG to a TIFF along with a color profile. Paint.NET is definitely applying the color profile and not discarding it in this case.

Share this post


Link to post
Share on other sites

Every time I save and re-open, her face gets more and more blushed ... (screencap from some an episode of Star Trek Discovery)

 

image.png

image.png

image.png

image.png 

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, Rick Brewster said:

Every time I save and re-open, her face gets more and more blushed ... (screencap from some an of Star Trek Discovery)

 

image.png

image.png

image.png

image.png 

 

 

 

 yeah the color changes, but now at a very rapid state. I don't recall doing that before the last update.

 

Share this post


Link to post
Share on other sites

I don't think I need an image from you anymore. I've reproduced the issue.

 

I think it's a bug in WIC, so I have to add some special casing logic in Paint.NET. It (WIC) is loading the color profile and providing it as an IWICColorContext, but it's also leaving the color profile in the EXIF metadata. So when the image is loaded, the color profile is applied, but it also survives in the file and gets applied the next time the image is loaded. Repeat ad nauseum.

Share this post


Link to post
Share on other sites

Ok so there is a chance my drawings will becoming again like it was before ? I don't think it will, but if you are here is worth to ask. Thanx

Share this post


Link to post
Share on other sites

The colors won't revert back to the original. They won't continue changing with each save/open cycle, however. They'll be stable.

 

You have backups, right? If data is important, you need to have backups. Especially if you're installing beta builds of any software. Personally I use CrashPlan, but there are lots of services you can use.

Share this post


Link to post
Share on other sites

I do have backups, with the originals but not with my recent work,..

Not a problem though, I will remade them. Actually I only need to change the colors. Anyway I'm very pleased that in the end I all worked out good.

Did I ever mention, if paint net will show the measurements in millimeters and not in centimeters I will be very pleased ?!  :)

 

 

Edit: I know I made some guys curious and I will show some screenshots to demonstrate that paint.net can be a very powerful tool if you know what to do !

 

the original scan:    https://prnt.sc/oaor76

 

and in the end will look like this:     https://prnt.sc/oaor76

 

Of course that just a faze. Other 3D software will be used after.

Edited by AsgardTM

Share this post


Link to post
Share on other sites

Sorry about that

 

http://prntscr.com/oaqby7

 

The original is not the same as the one I made screenshots right now, because is ruined and I need to replace all the colors with GIMP until another paint.net update will be available.

Regards.

Edited by AsgardTM

Share this post


Link to post
Share on other sites

Edit: Can I ask a favor? More like a life quality improvements.

I need to  block the left mouse button ONLY to move selection not to also rotate or whatever. Is a pain in the "arse" to always zoom in max to grab one pixel wide line to be moved, Please !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this