null54

G'MIC (03-28-2020)

Recommended Posts

@null54 I know that if I need to recreate one of my filters and convert it to pdn plugin, I'd do it from scratch. However, I'm wondering if it is possible to wrap gmic code within codelab. That would make it so much easier to convert filters in theory.

Share this post


Link to post
Share on other sites
1 hour ago, Reptillian said:

However, I'm wondering if it is possible to wrap gmic code within codelab. That would make it so much easier to convert filters in theory.

 

It should be possible to write a C++ DLL that uses libgmic, but you would have to call G'MIC in CodeLab's PreRender method.

 

I considered doing that when I wrote this plugin, but I decided it was easier to use G'MIC-Qt.

Writing the automatic UI generation code required for Paint.NET to natively use the G'MIC filters would be complicated.

Share this post


Link to post
Share on other sites
15 hours ago, null54 said:

 

It should be possible to write a C++ DLL that uses libgmic, but you would have to call G'MIC in CodeLab's PreRender method.

 

I considered doing that when I wrote this plugin, but I decided it was easier to use G'MIC-Qt.

Writing the automatic UI generation code required for Paint.NET to natively use the G'MIC filters would be complicated.

 

Yes, I was thinking of using PreRender method to call G'MIC-QT for converting filter. I'm not concerned with the user interface code as that's way easier to deal with. I'm more concerned with being able to access commands from g'mic-qt itself and using g'mic-qt commands.

Share this post


Link to post
Share on other sites

I hope someone can tell me what I'm doing wrong. I tried to use the plugin for the first time. Most of the filters work fine but I cannot get the Stylize filter to work.

 

I understand that I need to copy one layer to the clipboard and then apply the filter on another layer. As per @null54's instructions here, I copied the bottom layer and applied the filter on the top layer. I tried with a small image (180*198 px) of just two layers. I also tried it as per @Pixey's short video here, i.e. copied the top layer and applied the filter on the bottom layer. I tried all the combinations of copying one and working on the other, including switching between the "top" and "bottom" options on the filter's "Style" dropdown list.

 

Every time I get this:

75xKJdR.png

 

Share this post


Link to post
Share on other sites
2 hours ago, Djisves said:

I hope someone can tell me what I'm doing wrong

 

You need to switch the input layers to All for G'MIC to be able to recognize the second layer.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.