FredF

Can't open files while using Paint.net

Recommended Posts

When I start Paint.net version 4.1.4 and select Ctrl-O ( open file) the program does not react anymore.

When I select a file and choose open with paint.net, then I can modify that file in Paint.net and save the file.

PdnRepair.exe did not solve the problem.

 

The problem started after I installed something.

Uninstalling of that program did not solve the problem.

 

Versions 4.0 and 4.12 I can't use on the same reason. Version 3.5.11 works good. But there the functionality is not as good as in the 4.1.4 version.

 

How can I solve this problem??

Share this post


Link to post
Share on other sites
2 hours ago, FredF said:

The problem started after I installed something.

Uninstalling of that program did not solve the problem.

 

To better understand what happened, I think we'll need to know the name of that program.

Share this post


Link to post
Share on other sites

Well, if it was me and I was suspicious that something I'd downloaded was now interfering with the operation of my PC I'd be running a full anti-virus/anti-malware scan.

 

That is usually the 'solution' suggested by idiots whose first thought is to blame everything going wrong with their computer on such things but in this case, on the evidence presented, it seems justified.

 

I'd then use a system restore point from before the problem occurred and see if that fixed it. The system can be rolled back if it does not.

 

I'd also look in what's running at start up. CCleaner is good for this but be careful as that itself, thanks to AVAST, can install unwanted stuff. So perhaps better to use > Run and type msconfig  to get to Startup and see if there is anything there that shouldn't be. I'd also use the small and useful program AutoRuns for the same reason:-

 

https://www.youtube.com/watch?v=r7HZ1jzdEvk

 

But primarily what I'd suggest doing first is what I suggested for another poster here having a different problem a couple of weeks ago in this thread:--

 

 

https://forums.getpaint.net/topic/113466-null-error-when-trying-to-install/?tab=comments#comment-551081

 

 

That is to use System File Checker because the fact that recent PDN versions are now not working yet older ones are suggests a MS .NET Framework problem and that running sfc /scannow may fix it.

Edited by IHaveNoName
spelling, grammar, typos

Share this post


Link to post
Share on other sites

You can easily tell if some other software is messing with Paint.NET by starting your computer in "Safe Mode".  Once that's done, try running Paint.NET.  If it runs fine, the problem is somewhere else.

Share this post


Link to post
Share on other sites

Thank you for your reaction IHaveNoName and BoltBait! 

 

This afternoon I installed Paint.net 4.1.4 again and now the problem is gone!

 

I really don't know what went wrong.

When the problem occured  I scanned my computer at once with Kaspersky and MalwareBytes, but nothing was found.

 

Share this post


Link to post
Share on other sites

If you have your MS/Windows updates on automatic it could be that an update actually fixed the problem, particularly if it was a MS  .NET Framework corruption or version issue. The monthly 'quality rollouts', including this month's ones, always seem to have updates for that. 

Share this post


Link to post
Share on other sites

Yes, I have setted Update automatic, so this could be the case. 

I setted system restore point again. This settings was lost after I installed Windows again in January.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now