Jump to content

How do you disable auto-scroll when using the brush tool.


ande85
 Share

Recommended Posts

I've been trying to colorize a manga using the newst version of Paint.net, but whenever I get too close to the edge, it auto-scrolls super fast to the right/left. Yes, I am aware, don't be to close to the edge then works, but wouldn't it be easier to have an option to disable this from the start? Also, while I doubt it exists, is there any way to make the canvas area take up the full screen, with only the color pallet, and layer select visible?

 

Also, a problem from the old version, I randomly get a single line appearing on the screen. I don't know if it's because I'm using a drawing monitor or what, but if possible, is there anything I can do, like adjusting the mouse sensitivity etc. to stop this from happening? I tried using Photoshop a little, and this problem did not happen even once, therefore the problem appears to be native to this particular program.

Edited by ande85
Additional detail to save on creating a new topic
Link to comment
Share on other sites

Changing the canvas size doesn't help with anything. Since I have to be zoomed in really close, whenever I get too close to the edge, it auto-scrolls in that direction, and yes, it is very annoying. As for disabling fluid mouse input, I tapped on the screen, and immediately got a line going from it's previous location on the screen to where I clicked. Not entirely sure if that would eliminate future problems or not, but for now, I'll leave it unchecked and see what happens. The problem, originally, was that it would streak off in a straight line about half-way across the page at random whenever using the brush tool. I'm hoping this fixes that, otherwise I'm going to have to go back to Photoshop, and believe me, for colorization, it's bloody potato. You want just the color of one layer? Well too bad! Your getting a composite color of all layers, meaning said color is too dark for your intended purposes. Well...that and much (much) smaller file size for my intended purposes.

Link to comment
Share on other sites

Definitely don't un-check "Fluid mouse input". That doesn't affect anything like this and will just make brush and pencil drawing look worse.

 

A technique that can help is to get into the habit of scrolling away from the edge before you reach it. You don't have to use the scroll bars, which are pretty clumsy. You can actually scroll at any time by holding the spacebar and clicking and dragging. Once you get used to it, it's second nature.

 

If it's still problematic, I can maybe add an option to disable the auto-scrolling behavior. I'm hesitant to do this, however, because if it gets unchecked by accident then the user experience can become extremely frustrating.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Maybe it's just because *I* have never had a use for it, but the auto-scroll seems to be more of a burden than anything else. I'm serious...if it was taken out all-together I wouldn't miss it in the slightest. Mind you, that is for my own personal use and experience, so what it would be like for others is debatable. Also, if you could, at least turn the auto-scrolling speed down, and I mean by a lot. In half a second I'm halfway on the other side of the page. Personally I think more customization, and not less, would be of help here, but then again, I'm not bias-free, so you might want to take what I'm saying with a grain of salt.

 

Hmm...I've heard of some plugins for Paint.net. Maybe to meet half-way, you could make a plugin for Paint.net? This way it is enabled by default in the vanilla software, but with the plugin, it gives the ability to fine tune auto-scroll (example: scroll 10 twips in a given direction), or better yet, to disable it all-together. Odds are that if someone were using this plugin they would know about what is going on from the outset, and if the worse were to happen where they disabled the auto-scroll, the problem could be fixed by either going back to the plugin, or perhaps by removing the plugin, or deleting a config file. I, personally, am used to Firefox, and now Chrome, so I'm well used to having to install plugins (and grease monkey scripts) to get the functionality I prefer. Maybe by making things modular it would work better since the end user would have the customization and control they need.

 

 

 

EDIT:

 

Good news: for the last few days I had Fluid mouse input unchecked, and in that time, I haven't had a single issue with streaks going halfway across the page. As a test i toggled it back on, and yes, they came back almost immediately. Since I'm using a stylus with my drawing monitor (as apposed to what?) I think there may be a compatibility issue going on here that requires that option to be toggled off.

Edited by ande85
Issue that needs to be troubleshooted.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...