Sign in to follow this  
Rick Brewster

paint.net 4.1.1 is now available!

Recommended Posts

This is a hotfix for version 4.1 that fixes a few small bugs, reinstates some keyboard shortcuts, and adds 2 new languages.

 

If you’re using the Windows Store release, you should get the update automatically within the next few days.

 

For the Classic release, you can use the built-in updater by going to ⚙ Settings → Updates → Check Now. You can also download it directly from the website.

 

Thanks to @toe_head2001, @ReMake, and @Dandelion Sprout for helping out on this release!

 

Changes:

  • New: Ukranian translation (thanks @ReMake!)
  • New: Norwegian translation (thanks @Dandelion Sprout!)
  • Fixed a bug in the IndirectUI color wheel control where it wouldn't pick up the correct value for the alpha slider
  • Fixed a crash with the new Shapes that would sometimes occur because the resources file wasn't updated yet (probably due to a "you have to reboot" dialog at the end of updating that was ignored)
  • Reinstated the shortcut keys for the Adjustments menu, as this was a very unpopular change
  • Improved: IndirectUI angle chooser control now supports the UpDownIncrement property (thanks @toe_head2001!)

 

Enjoy!

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

Also, for the Store version, I would like to add that you can force the new version to install:

 

1. Open the Microsoft Store app
 

2. Click on the "..." button at the top right, then click "Downloads and Updates"

 

image.png

 

3. Click on big blue "Get updates" button

 

image.png

 

And, voila. You'll see something like this if it worked:

 

image.png

 

 

 

Share this post


Link to post
Share on other sites

Many thanks for the update, Rick.  I am using PDN with Parallel, and I noticed the performance is noticeably faster than predecessor.

 

In reading the thread about the color picker (inside Troubleshoot & Bug Report sub forum), I was wondering if it is possible for a future release to allow the paint brush and gradient to use left-click to set primary and right-click to set secondary colors?

Share this post


Link to post
Share on other sites

Unsure whether this is a plugin issue or a PDN itself issue but the way colour choice is shown in plugins - 0 Alpha - can make things a bit hit or miss at times for those of us who are or getting optically challenged.  At least it does for me.  The issue is worse the lighter the colour

 

0_alpha.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, welshblue said:

Unsure whether this is a plugin issue or a PDN itself issue

 

This bug was introduced in the latest build of Paint.NET.  Sorry about that.

 

I have already submitted a code fix for it in the official source code repository.  It will be fixed in the next release of Paint.NET.

 

I'm not sure what Rick's time table is for the next release, but it shouldn't be too long.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, BoltBait said:

Sorry about that

 

No worries.  It is what it is .. at least it's made me realise I need to visit the optician.  Every cloud and all that

Share this post


Link to post
Share on other sites

I really hate to complain, but I kind of can't avoid it here: this latest version has borked layers completely.  I work with a number of images with a huge number of layers (ie. well over 100), and now the program lags atrociously the moment I do anything with them.  If I turn a layer on or off, the program takes almost 5 seconds to register it, and that lag grows to almost 20 seconds if I'm enabling or disabling multiple layers at once.  Just scrolling through the list of layers causes it to hiccup, and if I try to use the mouse's scroll wheel, it's completely untenable as it jerks through the list at seemingly random intervals every 3 to 6 seconds.  I don't know what changed to cause this, but I would be very happy if the next version fixed it.

Share this post


Link to post
Share on other sites

There shouldn't have been any changes to cause that, but like @BoltBait pointed out, a performance trace and maybe a video will help immensely for me to figure it out.

Share this post


Link to post
Share on other sites

I had the same problem as @Sky_Render

 

Same file as I had the Rectangle Select problem on.  PDN had been open a few hours ... lots and lots of layers ... click on a layer no names displayed, some layers looked empty despite having stuff on -  just a rotating buffering symbol all up the layers window.  I thought it may have been a memory thing but it sorted itself out.

 

Half an hour later whenever I clicked on a different layer, PDN would minimise itself - did it about 10 times before I shut that file down.  

I kept PDN open with other files up and no further hassle when I re-opened that file

 

Will do a trace if it happens again

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this