Jump to content

Layers window not scrolling.


Ortro
 Share

Recommended Posts

Just as the title says.
The layers window no longer scrolls with mouse wheel when I have it active. Please help or fix!

This is the first time i've made a forum post, if i've got anything wrong please tell me.

 

 

 

Also if you could make layer folders a thing that'd be aces.

Edited by Ortro
Link to comment
Share on other sites

You're fine posting this here Ortro, and welcome to the forum :)

 

Are you able to post a screenshot of your layers window?

 

How many layers do you have in the image?

Link to comment
Share on other sites

Heres a scrn cap of my set up! Don't mind what i'm working on, I use the program for digital art.I know it looks weird from the cap.

 

Since the update installed the other day my mouses scroll wheel won't work for the layers window. Wether its 5 layers or 60 I just can't get it to work?
I can manually scroll using the scroll bar though.

 

Thankyou for the welcome! I've been using the forum for years for plugins, but this is the first time i've ever reported an issue.

Thankyou for the quick responce : )!

Scrn Cap Layers.png

Link to comment
Share on other sites

Try this just to humor me...,

 

Click on one layer to highlight it, then try scrolling....

 

Click on the layer window title bar and try scrolling....

Link to comment
Share on other sites

The layer window is selected when I attempt to scroll.
I click on the layer window, with either the mouse floating over it or off it and try scrolling but with both of those options it scrolls the program (image) behind it instead of the layers window.

Link to comment
Share on other sites

Well, something strange is going on with your system.

 

I'm running the latest build (4.0.21) and when my mouse is floating over the image, turning the mouse wheel scrolls the image.  When the mouse if floating over the list of layers, turning the mouse wheel scrolls the layers list.  Same for the history window.

 

So, the program has the right functionality.  There must be something special about your system that is preventing it from working property.

 

Have you recently changed your mouse or reconfigured it?  Are you running some new special mouse software?  Did you recently install a window's manager?

Click to play:
j.pngs.pngd.pnga.pngp.png
Download: BoltBait's Plugin Pack | CodeLab | and how about a Computer Dominos Game

Link to comment
Share on other sites

One more thing to check...

 

Click your start menu button and type "Settings" press enter.

 

On the settings screen, search for "Mouse" settings.

 

On the mouse settings screen, look to see if the following option is set: "Scroll inactive windows when I hover over them".  It should be "On".

 

When I change that setting to "Off", I get the same behavior you're experiencing.

Click to play:
j.pngs.pngd.pnga.pngp.png
Download: BoltBait's Plugin Pack | CodeLab | and how about a Computer Dominos Game

Link to comment
Share on other sites

Unfortunatley that doesn't look like an option on my computer.

I'm on windows 8.1 and in all the loctations for mouse settings I can't seem to find the, "Scroll inactive windows when I hover over them" option.

 

Could it be that the windows i'm on doesn't support all the newly updated paint.net functions?

Cap 1.png

Cap 2.png

Link to comment
Share on other sites

Yeah, maybe.
Oh well, Thankyou both for your help!
I allways back up my versions of paint.net before it updates just incase something goes wrong so I still have the older version attached to my PC and that seems to work fine with the scrolling. So its not the end of the world : ).

Until I have a change to update to windows 10 or the next version of paint.net comes out i'll stick to the older model.

 

Once again thankyou!

Link to comment
Share on other sites

8 minutes ago, toe_head2001 said:

For what it's worth, scrolling in the Layers window works fine on, the ancient, Windows 7.

Welp
All hail windows 7.

 

Maybe the install went wrong? The newer version uses a new .net framework right? so maybe?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...