Sign in to follow this  
olavrb

v4.0.20 dark theme bug when not active window

Recommended Posts

Hi!

 

Let me start by saying that I LOVE the new black theme! :) But it has a little bug:

 

When the Paint.NET window is not active, some places turn white. See this screenshot: 

6ApTTGD.png

 

- This happens on both of my laptops, both running Windows 10 1709 16299.192 en_US. One 'Pro' and one 'Pro for Workstation'.

- Happens both with theme set to auto, and dark.

- Windows theme is set to dark.

- Happens regardless of the "Show accent color on the following surfaces: Title bars" setting.

Edited by olavrb

Share this post


Link to post
Share on other sites

Did you just recently turn on the "show accent colors on: title bars" setting in Windows? If so, this will likely go away the next time you ... I think it goes away when you restart, or logout/login, or maybe even just when you restart the app. (I forget which). This isn't actually a new bug.

Share this post


Link to post
Share on other sites
On 10/01/2018 at 7:01 PM, Rick Brewster said:

Did you just recently turn on the "show accent colors on: title bars" setting in Windows? If so, this will likely go away the next time you ... I think it goes away when you restart, or logout/login, or maybe even just when you restart the app. (I forget which). This isn't actually a new bug.

No, I did not recently turn on that setting. There have been several restarts of my Windows laptop since I reported this, and the issue is still present. 
Also, it happens on both my laptops, so I think it's not a isolated case.

Happens with v4.0.21 too (nothing regarding this in the changelog, but thought I should mention it)

Share this post


Link to post
Share on other sites
On 1/10/2018 at 10:01 AM, Rick Brewster said:

Did you just recently turn on the "show accent colors on: title bars" setting in Windows?

 

3 hours ago, olavrb said:

No, I did not recently turn on that setting.

 

Well, you need to do that as described here:

 

https://forums.getpaint.net/topic/112124-paintnet-4020-beta-build-6560/?do=findComment&comment=539822

 

Share this post


Link to post
Share on other sites

No, this is a different visual glitch.

 

I think I've seen this though. Try going into the Windows theme settings again and "jiggle the handle." That is, change your settings to something else and then back again. Do this for the window color, and also for the "show accent color on: title bars" setting.

 

Sometimes this glitch happens with a fresh install or a freshly upgraded install of Windows 10. I think.

Share this post


Link to post
Share on other sites

What exactly are your Theme settings in Windows? Did you use any utility to "hack" the color values? I got another report from someone who said they used a registry editor or something so they could specify a true black #000000 color

Share this post


Link to post
Share on other sites
2 hours ago, Rick Brewster said:

"Remove focus from the program" ? I've never heard of that setting. 

 

You know what this.Blur() is?  Same thing.

 

He's saying, open paint.net and make the window not cover the entire screen.  Then, click on the desktop so that paint.net is no longer the active program.  When you do that, the top bar turns a stark white.

 

I really don't think it is a paint.net problem as Chrome does the same thing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this