Sign in to follow this  
Rick Brewster

paint.net 4.0.20 beta build 6560

Recommended Posts

Hey! Nice, but you have a some problems with invert colors it's scrolling, input, select box.. Look.. 

https://imgur.com/a/7haOZ our idea with invert

https://imgur.com/a/13iPb your idea..

 

PS. We have a some nice ideas.

  1. Possibility to lock (Pin) the Inst (panel) to header (top).
  2. Some edit borders in header menu..

Scr 1

https://imgur.com/a/k55yi

 

Scr 2

https://imgur.com/a/HB7lo

 

Scr 3

https://imgur.com/a/7haOZ

 

This two nice ideas make your software batter.. Thanks for good app.

We think, Dark Themes, PinMode, up version software to 5.0. Have a nice day.

 

 

Edited by COLOVE Products

Share this post


Link to post
Share on other sites

I'm seeing another handful of bugs in Win7 w/ Dark that I"ll be fixing.

 

There's a seam underneath the menus that goes away when you resize the window (or maximize it) -- I've fixed that.

 

There's also some problems with text headers in the Levels dialog getting clipped, and possibly elsewhere.

Share this post


Link to post
Share on other sites
44 minutes ago, Eli said:

The same bug is present when using "Resize". "Canvas Size" , "Dents", .

 

Also  in Polar Inversion.  Type a figure into the amount bar and it shoots up to maximum (4.00)  The Offset boxes do it too

 

Add Noise - the Coverage box is dicky too

Edited by welshblue

Share this post


Link to post
Share on other sites

I don't know if it pertains but the size in MJW's Paste from Clipboard and the coordinates in Red's Vanishing Point are very temperamental. They weren't like that before.

Share this post


Link to post
Share on other sites

This is more of a minor annoyance than a major issue, but some plugin UI's aren't displaying correctly in terms of color.

 

Examples:  Color Tint button text is white instead of black, making it difficult to see.

                     Color Flip/Rotate doesn't inherit your chosen Windows color; it is white, along with the button text.

 

There may be more, but I haven't opened every single plugin...that would take some time...

 

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, lynxster4 said:

This is more of a minor annoyance than a major issue, but some plugin UI's aren't displaying correctly in terms of color.

 

Are those plugins based on IndirectUI or are they custom?

Share this post


Link to post
Share on other sites
31 minutes ago, BoltBait said:

Are those plugins based on IndirectUI or are they custom?

 

27 minutes ago, toe_head2001 said:

Yeah, those have custom User Interfaces, which won't work 100% correctly without some tweaks by their authors

 

Well, those are things we will just have to live with when using 'dark theme'.  Some of these plugins are old, old...but I still use them.

Thank you for the quick reply... :)

Share this post


Link to post
Share on other sites

On the dark theme, some of the plug in icons in the menu are hard to see.

 

Pyrochild's Grid Warp, for example almost disappears into the menu background. I wonder if it's possible for plugin authors to code icons to switch between dark and light themes.

Share this post


Link to post
Share on other sites
2 hours ago, TrevorOutlaw said:

I wonder if it's possible for plugin authors to code icons to switch between dark and light themes.

There currently no official way for a plugin to detect which theme is active. I think Rick will eventual add this ability for plugins.

The CodeLab editor has a Dark theme also, and it would be cool if it automatically switch to that Dark theme when paint.net's Dark theme is active.

That is to say, CodeLab themes could be [Automatic, Light, Dark], once plugin can detect paint.net's theme.

 

The best option right now is to use an icon that works on both Light and Dark themes. (plugins should already be doing this for High Contrast accessibility...)

Share this post


Link to post
Share on other sites

Probably no big deal but I thought I would mention it. After upgrading to Fall creators edition - I had to install a new version of Acrobat reader to read PDF files. What I just noticed is the icon in the task bar shows as Paint.Net.

Adobe_In_Taskbar.png

 

I looked at the .exe for Adobe but it does not display a change icon choice. In Explorer the proper Adobe icon is displayed for PDF images as well.

Perplexed B)

 

Edit  Figured it out by deleting existing shortcuts - creating new ones - rebooting. Not 100% fixed. Still shows Paint.net icon in start menu and it won't let me unpin. Treated as a WIN10 issue

Edited by AndrewDavid
added solution

Share this post


Link to post
Share on other sites
1 hour ago, AndrewDavid said:

I had to install a new version of Acrobat reader to read PDF files.

Had to, eh? There are better choices than Abode Reader when it comes to PDF viewers. Can't Windows 10 already read PDF files without any additional software anyways?

Share this post


Link to post
Share on other sites

That's true. Edge, IE and Chrome are some examples. Reader as well, but it will be retired in the New Year.

I am so used to Adobe I had to install the new version because the old version disappeared.  And the new version does work better than the old one.

Just call me an old dog. B)'

Share this post


Link to post
Share on other sites
6 hours ago, AndrewDavid said:

Nor will it save the 2D format 

 

It saves 2D format for me but not Alpha Values.  Also more bad news ...

 

... but moved it to HERE

 

Edited by welshblue
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for these new version but I can not get used to the new dark theme. I can not find the icons even though they are there. Perhaps Dark Theme is not good for old eyes.

 

I must have a BUG in my eyes. :)

Edited by Eli

Share this post


Link to post
Share on other sites
4 hours ago, Eli said:

Thanks for these new version but I can not get used to the new dark theme. I can not find the icons even though they are there. Perhaps Dark Theme is not good for old eyes.

 

I must have a BUG in my eyes. :)

 

:arrow-up: like @Eli I too can't get used to the Dark Theme - but never mind - we have choices, which is nice B) 

 

I am also having trouble pasting numbers into settings in @MJW's Height Map Texture Shader :(

Share this post


Link to post
Share on other sites
13 hours ago, AndrewDavid said:

@Ego Eram Reputo Thought I would post the issue here instead of the plugin thread for planetoid. It is now failing to retain settings (Alpha=0) in saved files. Nor will it save the 2D format as described in @welshblue's latest tutorial. Win 10 Fall Creators update.

B)

Thanks for the report AndrewDavid. I'll round up the usual suspects and see if I can extract a confession ;)

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this