Jump to content

Can't switch tools using hotkeys after clicking on any window besides the main one.


Giik
 Share

Recommended Posts

See title. After clicking any of the secondary windows - colors, layers, etc. - then I can't use hotkeys to switch tools until I click on the main window again. This is incredibly annoying, as I usually accidentally use a tool I wasn't intending to, so I either have to ctrl+z or click on the header of the main window every single time I want to switch a layer or adjust colors.

 

I don't know if this is exclusive to my computer, so here's the diagnostics log just in case:

Spoiler

Application    paint.net 4.0.19 (Final 4.19.6484.39094)
Build Date    Monday, October 2, 2017
Install type    Classic
    
Hardware accelerated rendering (GPU)    False
Animations    True
DPI    96.00 (1.00x scale)
Language    en-US
    
OS    Windows 10 x64 (10.0.15063.0)
.NET Runtime    4.0.30319.42000
Physical Memory    8,091 MB
    
CPU    Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
    Speed    ~3492 MHz
    Cores / Threads    4 / 4
    Features    DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE
    
Video Card    AMD Radeon (TM) R9 390 Series
    Dedicated Video RAM    8,169 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,045 MB
    Vendor ID    0x1002
    Device ID    0x67B1
    Subsystem ID    0x2358148C
    Revision    128
    LUID    0x00009780
    Flags    None
    Outputs    1
    
Video Card    Intel(R) HD Graphics 4600
    Dedicated Video RAM    112 MB
    Dedicated System RAM    0 MB
    Shared System RAM    2,048 MB
    Vendor ID    0x8086
    Device ID    0x0412
    Subsystem ID    0xD0001458
    Revision    6
    LUID    0x0000A037
    Flags    None
    Outputs    0
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,045 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x0000A00B
    Flags    Software
    Outputs    0

 

Link to comment
Share on other sites

I shouldn't, but sometimes I have to. I'm not sure what causes it; I just launched pdn again to test it and just hovering over the main window works, but last night when I was working on some things then I definitely needed to click on the window every time. I had it open for a while and had several images open at the same time when I noticed that bug.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...