Jump to content

Vanishing Cursor


MJW
 Share

Recommended Posts

Lately I've had several occurrences of  the PDN cursor disappearing. When I move the mouse outside the PDN window, the cursor is visble, and when it's within the PDN window, everything works normally other than the lack of a visible cursor. I tried a few things, such as changing the Tool (and hence type of cursor), but haven't found any way to make the cursor visible again.

Link to comment
Share on other sites

Some additional infos would be helpful, I think.

 

Updated mouse- or graphic card driver or some special functions/enhancements for your mouse? Any possibly problematic Windows Theme? What about hardware accelaration in PDN?

Edited by IRON67
Link to comment
Share on other sites

Application version: paint.net 4.0.13 (Final 4.13.6191.1824)
OS Version: 10.0.14393.0 Workstation x64
.NET version: CLR 4.0.30319.42000 x64, FX 4.6
Processor: "Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz" @ ~3193MHz (4C/4T, DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE)
Physical memory: 8108 MB
Video card: Intel(R) HD Graphics 4600 (v:8086, d:412, r:6), Microsoft Basic Render Driver (v:1414, d:8C, r:0)
Hardware acceleration: True (default: True)
UI animations: True
UI DPI: 96.00 dpi (1.00x scale)
UI theme: Aero/Aero + DWM (Aero.msstyles)
Updates: True, 4/5/2017
Locale: pdnr.c: en-US, hklm: en-US, hkcu: en-US, cc: en-US, cuic: en-US

Nothing special about my mouse functions or parameters. Defaults except perhaps the motion speed. My mouse is a standard HID-compliant Dell USB mouse with the Microsoft driver.

Link to comment
Share on other sites

It happened again, so I tried disabling hardware acceleration. It had no effect, I don't know, though, if that change takes place immediately or not until PDN is restarted.

 

EDIT: I also tried re-enabling Hardware Acceleration, without any affect, but after I went to add this comment and returned to PDN, the cursor was back. I don't know if it was something I did, or if I just had to wait long enough.

Link to comment
Share on other sites

From the lack of response, I seem to be about the only one experiencing this problem, but I'm certainly experiencing it to an annoying degree. It's very bothersome. I have to restart PDN, which causes me to lose all the current plugin settings. It seems to always begin when I run a plugin. One time the cursor returned after a while, but that was the exception. I've waited for many minutes without the cursor reappearing.

Link to comment
Share on other sites

Thanks. Next time it occurs I'll try disabling Animations and see what happens. (I don't believe the last time it occurred I had any active selections, which is about the only thing I can think of that's animated.)

 

I thought Windows Areo was a Windows 7 thing, back when the window design was a bit elegant, not the current utilitarian squared-off-corner look.

Link to comment
Share on other sites

1 hour ago, MJW said:

I thought Windows Areo was a Windows 7 thing

Right, but not only. In your log you can see the entry:

Quote

UI theme: Aero/Aero + DWM (Aero.msstyles)

 

It seems, that your Windows uses a NON-Classic theme, so that an responding "Color scheme" in PDN is set.

On my Windows 7 with an Classic theme without Aero UI theme is "Classic".

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...