Jump to content

Wiggling Transparency Checkerboard (150% zoom v4.0.13)


Recommended Posts

Nice pic ;) - I see that all the time - I thinks its your CPU asking for a beak - or your memory has reached capacity. But that is only my opinion. I run a lot of effects that I think do not get out of memory as well as they should. A restart seems to solve that shaker effect. Thought it was just my eyes asking for a rest.

 

AndrewCorrectSize_Signature.png

qG3vze.png

 

Link to comment
Share on other sites

Paint.net uses tiled rendering. That specific tile is updating (redrawing).

 

As MJW says, please disable Hardware Acceleration in the Settings of paint.net, and see if it makes a difference.

Settings: User Interface

 

Please also post your System Diagnostic information.

Settings -> Diagnostics -> Copy to Clipboard

Settings: Diagnostics

Link to comment
Share on other sites

Application    paint.net 4.0.13 (Final 4.13.6191.1824)
Build Date    December 13, 2016
    
Hardware accelerated rendering (GPU)    False
Animations    True
DPI    96.00 (1.00x scale)
Language    en-US
    
OS    Windows 10 (10.0.14393.0)
.NET Runtime    4.0.30319.42000
Physical Memory    8,143 MB
    
CPU    Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz
    Architecture    x64 (64-bit)
    Process Mode    64-bit
    Speed    ~3193 MHz
    Cores / Threads    4 / 4
    Features    DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE
    
Video Card    NVIDIA GeForce GT 720
    Dedicated Video RAM    995 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,071 MB
    Vendor ID    0x10DE
    Device ID    0x1286
    Subsystem ID    0x108710DE
    Revision    161
    LUID    0x00008CA6
    Flags    None
    Outputs    1
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,071 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x00009558
    Flags    Software
    Outputs    0

 

Here's mine if you see anything unusual. I turned off the hardware acceleration and will let the post know if I see it again.

 

MGT9iTs.png

qG3vze.png

 

Link to comment
Share on other sites

This is due to rounding errors based on the size of the invalidation rectangle. It's a bug that keeps coming back everytime I think I've fixed it. But, it's purely a visual artifact and nothing bad is actually happening.

 

The invalidation rectangle is the part of the screen that needs to be redrawn. Those corner handles are fading in and out, but they don't change their appearance on every frame. And the selection outline is animating as well, but it also doesn't change every frame. So sometimes the invalidation rectangle surrounds the whole selected area plus the handles, but sometimes it only surrounds the selected rectangle. And at non-integral (anything other than 100%, 200%, 300%, etc.), you just get rounding errors. And there's some line or two of code that is incorrectly rounding up when it should round down, or vice versa. And it's difficult to reproduce this, and it's difficult to figure out which line of code to tweak, and it's difficult to test to make sure that some other and bigger problem wasn't introduced with the fix.

 

Sometimes the rounding error is worse with hardware acceleration. Sometimes it's worse with software rendering.

 

So, tl;dr ...  ¯\_(ツ)_/¯

  • Upvote 3

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...