Jump to content

Custom Shape Preview issue in 4.0.9


Recommended Posts

In previous versions, custom shapes looked like this:

SStep10.png

Now, in version 4.0.9, I just noticed that they look like this:

CustomShapeTrouble.png

Notice the ones outlined in red are cut off.

Diags:

 

Application	paint.net 4.0.9 (Final 4.9.5848.30436)
Build Date	Tuesday, January 05, 2016
	
Hardware accelerated rendering (GPU)	True
Animations	True
DPI	96.00 (1.00x scale)
Language	en-US
	
OS	Windows 7 Service Pack 1 (6.1.7601.65536)
.NET Runtime	4.0.30319.42000
Physical Memory	12,195 MB
	
CPU	Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
    Architecture	x64 (64-bit)
    Process Mode	64-bit
    Speed	~3392 MHz
    Cores / Threads	8
    Features	DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE
	
Video Card	Intel(R) HD Graphics Family
    Dedicated Video RAM	64 MB
    Dedicated System RAM	0 MB
    Shared System RAM	1,632 MB
    Vendor ID	0x8086
    Device ID	0x0102
    Subsystem ID	0x20028086
    Revision	9
    LUID	0x000073A7
    Flags	None
    Outputs	1
Is anyone else seeing these things get cut off?

Also, when drawing shapes, the handles are being put in the wrong place:

BrokenAgain.png

This issue was not present in version 4.0.6 release build.

post-44727-0-83033500-1460136539_thumb.p

post-44727-0-98765300-1460158996_thumb.p

Click to play:
j.pngs.pngd.pnga.pngp.png
Download: BoltBait's Plugin Pack | CodeLab | and how about a Computer Dominos Game

Link to comment
Share on other sites

Well I mostly use PDN v3.5.11 since I'm always in Linux. I do have PDN v4.0.9 installed in a VM running Win7x64 SP1, so I downloaded your Shapes pack to see. I can confirm the same problems you see. It seems to only effect your shapes however. No problems with other shapes I've tried.

69unju0.gif

Link to comment
Share on other sites

I have tested the three which you mention (in v4.0.9) and find:

 

1.  Envelope appears 'broken' in the Shapes window - same as you. 

 

2.  Utility folders also broken - as you see.

 

3.  Bus - same as you, handles only on the bottom rectangle.

 

I also tried a few other shapes, and they were fine.

Edited by Pixey

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

I also see the same thing as you, BoltBait.  Shapes cut-off in preview and handles in wrong place.

 

Running version 4.0.9.  All other shapes seem to be okay.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...