MJW Posted February 6, 2016 Share Posted February 6, 2016 (edited) I working on something related to the PropertyBased UI controls, and I'm not sure of the best names for them. The names will be part of method names. The titles of the controls used in CodeLab are: IntSliderControl CheckboxControl ColorWheelControl AngleControl PanSliderControl TextboxControl DoubleSliderControl ListBoxControl RadioButton ReseedButtonControl MultiLineTextboxControl RollControl The PropertyControlTypes are: Slider CheckBox ColorWheel AngleChooser PanAndSlider TextBox DropDown RadioButton IncrementButton RollBallAndSliders There are also the font list and pixel op controls from CodeLab, which I also want to include. Some names I'm considering are: IntegerSlider or IntSlider Checkbox or CheckBox ColorWheel or ColorChooser AngleChooser or AngleControl DoubleVector or PanControl Textbox or TextBox (I want the capitalization to match CheckBox, so either Textbox and Checkbox, or TextBox and CheckBox) DoubleSlider ListBox or Listbox or DropDownList RadioButtons (probably use the plural version, since there are always more than one) or RadioButtonList IncrementButton (which is what the function more generally is) MultiLineTextbox or MultiLineTextBox RollControl or ThreeDControl FontList or FontChooser PixelOps or BlendOps or PixelBlendOps or PixelOpList or BlendOpList (I seem to recall the official name for the pixel ops changed from one thing to another) Perhaps it seems silly, but I'm quite particular about naming things, so I was hoping for suggestions for the best descriptive name for each control. Edited February 6, 2016 by MJW Quote Link to comment Share on other sites More sharing options...
Join the conversation
You can post now and register later. If you have an account, sign in now to post with your account.