Sign in to follow this  
Simon Brown

AVI Frame Importer: AVIImport Version 4.0

Recommended Posts

Simon Brown    38
Bugs found:

1.) This plugin leaves an aviimporttemp.avi in the temporary files directory (%TEMP%).

aviimporthq7.png

It's meant to do that so that the dll can find the file.

The fact is that it leaves it there, when it should be deleted after the plug-in is finished with it.

I'll sort that out. Sorry.

Share this post


Link to post
Share on other sites

Has anyone tried what I posted as second bug? This is a massive problem, I can't use the plugin if it changes the save settings to a funny farm.

To make it clear, when I select a file type (from a plugin, not the built-in ones!) I don't get the corresponding file type but the one above!

Share this post


Link to post
Share on other sites
Geoff    0
Has anyone tried what I posted as second bug? This is a massive problem, I can't use the plugin if it changes the save settings to a funny farm.

To make it clear, when I select a file type (from a plugin, not the built-in ones!) I don't get the corresponding file type but the one above!

I too have been trying out the plug-in and have found no related issues with your file type problem. I also noticed that in your save as menu you have available "optimized .png", ".jpg 2000", ".psd" and ".pcx". As these file types do not come standard with Paint.NET, one of these will be interfering with the AVIImport plug-in. Just as a test remove all of the "additional" file types except one(1) from the File Typse folder to find out which one is doing the interfering, do this for all of them (4), and let me know how you go.

Geoff

Share this post


Link to post
Share on other sites
Leif    2
Has anyone tried what I posted as second bug? This is a massive problem, I can't use the plugin if it changes the save settings to a funny farm.

To make it clear, when I select a file type (from a plugin, not the built-in ones!) I don't get the corresponding file type but the one above!

For me the opti PNG saves as an animated curser. And IrfanView cant recognice the file. Something is not as it is supposed to bee.

Also, I personally don’t like the new prevue. I just cant se what I am doing. Then I would have preferred the long loading time. Is some sort of costume settings possible?

Share this post


Link to post
Share on other sites
Simon Brown    38
Has anyone tried what I posted as second bug? This is a massive problem, I can't use the plugin if it changes the save settings to a funny farm.

To make it clear, when I select a file type (from a plugin, not the built-in ones!) I don't get the corresponding file type but the one above!

For me the opti PNG saves as an animated curser. And IrfanView cant recognice the file. Something is not as it is supposed to bee.

Also, I personally don’t like the new prevue. I just cant se what I am doing. Then I would have preferred the long loading time. Is some sort of costume settings possible?

I'll allow custom setting.

EDIT: I've tried that now and it doesn't work - I guess Paint.NET will not let plugins create registry entries - but the new version will include bigger thumbnails.

Share this post


Link to post
Share on other sites
Leif    2

Thumbnail size is good now. I can live with that. :D

But strange things are still happening in the file format when using save as. The problem Fisherman's Friend talked about.

Share this post


Link to post
Share on other sites
Simon Brown    38
Thumbnail size is good now. I can live with that. :D

But strange things are still happening in the file format when using save as. The problem Fisherman's Friend talked about.

Don't Know - but in this version I did what you suggested and put in a blank "Save As" function.

Share this post


Link to post
Share on other sites
Simon Brown    38
I now can't import any .avi's videos, even the ones which I have used with previous versions of this software.

Probably because I increased thumbnail size. I'll try to find a way around that.

Edit: What about videos that worked with the first ever version?

Share this post


Link to post
Share on other sites
Andrew D    0
I now can't import any .avi's videos, even the ones which I have used with previous versions of this software.

Probably because I increased thumbnail size. I'll try to find a way around that.

Edit: What about videos that worked with the first ever version?

Don't work in this version.

Share this post


Link to post
Share on other sites
Simon Brown    38
I now can't import any .avi's videos, even the ones which I have used with previous versions of this software.

Probably because I increased thumbnail size. I'll try to find a way around that.

Edit: What about videos that worked with the first ever version?

Don't work in this version.

Does clock.avi?

Share this post


Link to post
Share on other sites
Andrew D    0
Probably because I increased thumbnail size. I'll try to find a way around that.

Edit: What about videos that worked with the first ever version?

Don't work in this version.

Does clock.avi?

Never tried it. I just used my own .avi's which I've made.

Share this post


Link to post
Share on other sites
Andrew D    0
Never tried it. I just used my own .avi's which I've made.

Does the update work?

Yes, though the thumbnail is absouletely ugly, and it seems to have a little bug in the slider.

Share this post


Link to post
Share on other sites
Simon Brown    38
Never tried it. I just used my own .avi's which I've made.

Does the update work?

Yes, though the thumbnail is absouletely ugly, and it seems to have a little bug in the slider.

Screenshot?

Share this post


Link to post
Share on other sites
Simon Brown    38
AVIImport Dialog:

post-44714-127041837763_thumb.png

[attachment=0]Chamber Doors As Test resized.jpg[/attachment]

There.

What about the slider bug?

The next version will allow you to customise the thumbnail size as well as the default slider position.

Share this post


Link to post
Share on other sites
Andrew D    0
What about the slider bug?

Check my image again, towards the end of the slider. There is a marker, then a marker close to it which is out of proportion to the other markers.

Share this post


Link to post
Share on other sites
Simon Brown    38
What about the slider bug?

Check my image again, towards the end of the slider. There is a marker, then a marker close to it which is out of proportion to the other markers.

That's because the framework puts an additional marker at each end. Does it matter?

Share this post


Link to post
Share on other sites
Andrew D    0
What about the slider bug?

Check my image again, towards the end of the slider. There is a marker, then a marker close to it which is out of proportion to the other markers.

That's because the framework puts an additional marker at each end. Does it matter?

It's just unpleasent to look at. And it only happens at one end, not both.

Share this post


Link to post
Share on other sites
Andrew D    0
Fixed. When I get round to it - I will post the latest version. Any feature suggestions apart from new file types?

So we are also getting the new dialog settings aswell?

Anyways, I guess, a way to import a video of some sort, split it into frames, and then allows you to choose an effect to apply to the video, and then put the frames back into the filetype. I guess that's more of just a plug-in rather than a file-type though, but it would bring batch processing to PDN, and some batch processing is for video making.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this