Sign in to follow this  
Followers 0
moc426

Align Object Plugin - Updated 06/17/2007

211 posts in this topic

The current UI is fine just the way it is.

Agreed. If it ain't broke... Yeah, it seriously pains me to say "ain't"

0

Share this post


Link to post
Share on other sites

Why not have it align the user's selection by using sliders for both X and Y? I mean that only if it is possible. Wouldn't that also eliminate the fact that they have to use the plugin against a transparent background?

0

Share this post


Link to post
Share on other sites

I have downloaded both the .dll and and the source, but I do not know how to install this plugin. Please can anyone help me?

0

Share this post


Link to post
Share on other sites

You can align to selection, but the layer still needs transparency, otherwise there is nothing to align as the entire object fills your selection. If you want to slide your object on x or y, its not aligning it, you can just use the move selected pixels tool :MoveTool:

Why not have it align the user's selection by using sliders for both X and Y? I mean that only if it is possible. Wouldn't that also eliminate the fact that they have to use the plugin against a transparent background?
0

Share this post


Link to post
Share on other sites
It's not too clear what your issue is. I'm sure that the plugin is working 'as designed' and its function is logically correct.

well for me using two objects separate from each other doesn't work at all

0

Share this post


Link to post
Share on other sites
I am not sure if you mean this but ...

2 objects on a layer are considered one object and WILL keep the same space between them, if you have each object on a different layer, then its a different object.

demo1_1.png

demo2_1.png

lol yeah thats exacly what I mean

0

Share this post


Link to post
Share on other sites

Thanks for the updated sources files.

Using VS 2005 express, I can't open the dialog form in design view! Related to abstract mode...

Could you tell me if you know why it is so!

0

Share this post


Link to post
Share on other sites

The class AlignPluginConfigDialogBase can be designed, but is not the first class in the file. Visual Studio requires that designers use the first class in the file. Move the class code so that it is the first class in the file and try loading the designer again. 
Hide     

at System.ComponentModel.Design.Serialization.CodeDomDesignerLoader.EnsureDocument(IDesignerSerializationManager manager)
at System.ComponentModel.Design.Serialization.CodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager manager)
at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager serializationManager)
at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.DeferredLoadHandler.Microsoft.VisualStudio.TextManager.Interop.IVsTextBufferDataEvents.OnLoadCompleted(Int32 fReload) 

That's the error message I recieved when opening up the design form.

0

Share this post


Link to post
Share on other sites

I did the form like pdn source does, you can't open it in designer.

Thanks for the updated sources files.

Using VS 2005 express, I can't open the dialog form in design view! Related to abstract mode...

Could you tell me if you know why it is so!

0

Share this post


Link to post
Share on other sites

This plug-in doesnt seem to be 100% compatible with 3.20

ex. i click center vertical alone nothing will happen same with center middle

0

Share this post


Link to post
Share on other sites
This plug-in doesnt seem to be 100% compatible with 3.20

ex. i click center vertical alone nothing will happen same with center middle

Working fine here.

0

Share this post


Link to post
Share on other sites
This plug-in doesnt seem to be 100% compatible with 3.20

ex. i click center vertical alone nothing will happen same with center middle

Mabye because your not working with a transparent image, or it's already centered?

0

Share this post


Link to post
Share on other sites

It works wonderfully for me. You do know that a single non-transparent pixel throws the whole thing off, right?

0

Share this post


Link to post
Share on other sites
Its not centered, the image is on a transparent area, doesn't work.

That's because there is some "left over" pixel on your image, either 1 small dot.

Or a pxiel that's low alpha and not visible.

Just remember happened to me too. :?

0

Share this post


Link to post
Share on other sites

I've had a straY 100 pixies or two this is my solution, for those nastys,

use outline 1 pix wide

they now show up

so hit the back button and erase them as you have just found the offenders.

0

Share this post


Link to post
Share on other sites
I've had a straY 100 pixies or two this is my solution, for those nastys,

use outline 1 pix wide

they now show up

so hit the back button and erase them as you have just found the offenders.

Excellent fix, Oma! I never even thought of that.

Using two Pyrochild plugins at the same time...hehe...

0

Share this post


Link to post
Share on other sites
Using two Pyrochild plugins at the same time...hehe...

... Align Object isn't mine... or am I misunderstanding something?

0

Share this post


Link to post
Share on other sites

Oh, carp. You're right, as I knew you would be...It's just so awesome that I figured...

:-) Just kidding. I don't know where I got the idea that AI was yours. Whoops!

EDIT: Sorry, moc426! I love this plugin, and you're a great programmer.

0

Share this post


Link to post
Share on other sites
This plug-in doesnt seem to be 100% compatible with 3.20

ex. i click center vertical alone nothing will happen same with center middle

I've this bug :(

And other crashs.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0