crazy4videogames

Installation problem, installed .net framework 4.6.2

11 posts in this topic

Hello. I opened the paint.net installer. It said that it would install .net framework 4.6.2 and paint.net. After it said it had successfully installed .net framework 4.6.2, a new window pops up that says "setupfront.exe could not run". It says that I need .net framework version 4.6 when the installer installed it for me (or so it said.) I tried again but the same thing occurred. I installed .net framework 4.6.2 off Microsoft's website and it said that it successfully installed it and that I would need to restart the PC. I restart the PC. Try to run the installer again. It says it will install .net framework 4.6.2 and paint.net. I click ok. It then goes to install .net framework 4.6.2 and after it claims to have installed it successfully, I get the same message. That "setupfront.exe" couldn't run due to not having .netframework version 4.6 when I installed it. I installed through Microsoft's website and through the paint.net installer. I've checked the common install errors section and couldn't find this problem. My windows version is windows 8. I downloaded the paint.net installer from the paint.net website and it is the installer for version 4.0.16. Please help. Thank you for reading.

0

Share this post


Link to post
Share on other sites

Read this thread:

 

Starting on step 4, follow each step and post your progress here.

 

0

Share this post


Link to post
Share on other sites
On 16/05/2017 at 5:18 PM, BoltBait said:

Read this thread:

 

Starting on step 4, follow each step and post your progress here.

 

Ok, thank you for the reply. I ran the install and uninstall diagnostics and it said to select the program (paint.net) that I am trying to install from the list of programs. It wasn't listed so I clicked on not listed. I also tried to find .net framework but I couldn't find that too. There wasn't much the diagnostic could do from then on. I have not done step 2 but that is because the link leads me to visual C++ redistributable 2015 installation and I already have that installed as it is listed in the programs list from the control panel. I have downloaded and installed .net framework 4.6.2 both from the Microsoft installer and the paint.net installer. It said that it was installed successfully from both installers. I ran the .net framework diagnostic and for the version for the program to search for, 4.6.2 was not listed so I chose 4.5 which was the highest on the list. Here's the log:

======================================================================
[05/17/17,20:41:56] Beginning of new SetupVerifier activity logging session
[05/17/17,20:41:56] Build created on October 26, 2016
[05/17/17,20:41:56] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
[05/17/17,20:41:56] Activity log file location: C:\Users\Shirley\AppData\Local\Temp\setupverifier_main_05-17-17_20.41.56.txt
[05/17/17,20:41:56] Error log file location: C:\Users\Shirley\AppData\Local\Temp\setupverifier_errors_05-17-17_20.41.56.txt
[05/17/17,20:41:56] Windows build version from registry: 9200.17617.amd64fre.win8_gdr.151230-0600
[05/17/17,20:41:56] Detected operating system: Windows 8 (x64)
[05/17/17,20:41:56] Windows directory: C:\windows
[05/17/17,20:41:56] System directory: C:\windows\system32
[05/17/17,20:41:56] Program Files directory: C:\Program Files (x86)
[05/17/17,20:41:56] Common Files directory: C:\Program Files (x86)\Common Files
[05/17/17,20:41:56] Install state for .NET Framework 1.0: not installed.
[05/17/17,20:41:56] Install state for .NET Framework 1.1: not installed.
[05/17/17,20:41:56] Install state for .NET Framework 2.0: installed with service pack 2.
[05/17/17,20:41:56] Install state for .NET Framework 3.0: installed with service pack 2.
[05/17/17,20:41:56] Install state for .NET Framework 3.5: installed with service pack 1.
[05/17/17,20:41:56] Install state for .NET Framework 4 Client: installed with no service packs.
[05/17/17,20:41:56] Install state for .NET Framework 4 Full: installed with no service packs.
[05/17/17,20:41:56] Install state for .NET Framework 4.5: installed with no service packs.
[05/17/17,20:41:56] Install state for .NET Framework 4.5.1: installed with no service packs.
[05/17/17,20:41:56] Install state for .NET Framework 4.5.2: installed with no service packs.
[05/17/17,20:41:56] Install state for .NET Framework 4.6: not installed.
[05/17/17,20:41:56] Install state for .NET Framework 4.6.1: not installed.
[05/17/17,20:41:56] Install state for .NET Framework 4.6.2: not installed.
[05/17/17,20:41:56] Not adding product '.NET Framework 1.0' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 1.1' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 2.0' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 3.0' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 3.5' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 4.6' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 4.6.1' because it is not currently installed
[05/17/17,20:41:56] Not adding product '.NET Framework 4.6.2' because it is not currently installed

 

0

Share this post


Link to post
Share on other sites

You need to do this:

 

Download THIS (.NET Framework v4.6.2) and install it.

 

THEN try installing paint.net again.

1

Share this post


Link to post
Share on other sites

Weird. 4.6.2 won't install on 8.1, but it will on 7 SP1 ... https://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx

 

Either way, Paint.NET only requires .NET 4.6. If .NET 4.6+ isn't installed then Paint.NET's intaller will launch the .NET 4.6.2 installer ... I did not realize that 4.6.2 didn't work on Windows 8!

 

However, Windows 8 is dead. Just like toe_head2001 says, you should install 8.1, it's a free update. That is the solution. (better yet, upgrade to 10 ...)

0

Share this post


Link to post
Share on other sites

(even better, install .NET 4.7 ...)

0

Share this post


Link to post
Share on other sites

Aww. That's a shame. I wonder why windows 8 isn't supported but windows 7 sp1 is. I don't know why but I am a bit reluctant to install windows 8.1 ._. If possible, is there a way I can download an older version of paint.net? One that will run on .net framework 4.5 or does every version only run on 4.6? Well thanks for the help anyways.

0

Share this post


Link to post
Share on other sites

Older versions of paint.net are not supported here. Why not upgrade your O/S?  Lagging behind is going to cause you more and more issues.

0

Share this post


Link to post
Share on other sites

The latest version of Windows 8 is Windows 8.1.

 

When you see Windows 8.1, just think of it as Windows 8 SP1.

 

Just like you wouldn't ever run Windows 7 anymore in favor of Windows 7 SP1.

 

So let me repeat: the solution is to install Windows 8.1. You should not be holding on to Windows 8. 

 

We've told you the solution. Please go apply it!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now