Sign in to follow this  
Followers 0
Ego Eram Reputo

Incompatible Plugins - an incomplete list (updated for 4.0.5284)

137 posts in this topic

Added

 

RotateZoom+  (Effects > Distort).  Tested with 4.0.5168.  Full error message: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentOutOfRangeException: Increment value 0.01 is invalid - it must be less than current Maximum (-0.5).

 

ScreenPixel (Effects > Distort).  Tested with 4.0.5168.  Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.Effects.AmountEffectConfigDialog'

0

Share this post


Link to post
Share on other sites

Added

 

Single Hue (Effects > Color) Ed Harvey.  Tested with 4.0.5168.  Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.SystemLayer.UI' from assembly 'PaintDotNet.SystemLayer, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

 

Sparkle_Stars.dll (Effects > Render). Knotts.  Tested with 4.0.5168.  Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.Effects.ThreeAmountsConfigDialog'

0

Share this post


Link to post
Share on other sites

Added

 

Single Hue (Effects > Color) Ed Harvey.  Tested with 4.0.5168.  Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.SystemLayer.UI' from assembly 'PaintDotNet.SystemLayer, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

 

 

It's working for me. I manically abused the UI and no crashes. Strange

Edited by welshblue
0

Share this post


Link to post
Share on other sites

It's the old one. Not Ed's new version. I suspect you have the new version installed?

0

Share this post


Link to post
Share on other sites

Clipwarp, new and old, are crashing in v4 for me :/ .  Still working on v3.5.8 though - very confusing for moi :( .  Oh - and I did try re-installing with latest versions of the plugin.

0

Share this post


Link to post
Share on other sites

I am sure I had Clipwarp working. Please post the crash/error message.

Thanks.

0

Share this post


Link to post
Share on other sites

I've got it.  ClipWarp seems to have been broken by the latest release.  Strange.

 

ClipWarp  Tested with 4.0.5168.  Exception details:  System.TypeLoadException: Could not load type 'PaintDotNet.DataObjectExtensions' from assembly 'PaintDotNet.Core, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

 

ClipWarpNew  Tested with 4.0.5168. Exception details: System.TypeLoadException: Could not load type 'PaintDotNet.DataObjectExtensions' from assembly 'PaintDotNet.Core, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

0

Share this post


Link to post
Share on other sites

Added:

 

(GPU) Motion Blur.  

 

Tested with 4.0.5168 as reported here: http://forums.getpaint.net/index.php?/topic/19364-hardware-accelerated-blur-pack-v24/page-3#entry406283

 

Full error message: PaintDotNet.WorkerThreadException: Worker thread threw an exception ---> System.TypeLoadException: Could not load type 'PaintDotNet.Rendering.PointFUtil' from assembly 'PaintDotNet.Base, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

0

Share this post


Link to post
Share on other sites

But it's (Motion Blur) working fine for me in beta 4.0.5168  :P 

0

Share this post


Link to post
Share on other sites

But it's (Motion Blur) working fine for me in beta 4.0.5168  :P

 

The built in one is fine ... it's the superfast one by Bruce Bowyer Smith having the issues  ;)

0

Share this post


Link to post
Share on other sites

Thanks @WB for explaining that :| .

 

As reported by Kelly - TR's Displacement map is crashing v4.  I will try to attach the crash log.

Hidden Content:
File: C:\Program Files\Paint.NET\Effects\CurtisBlack.Effects.dll

Name: CurtisBlack.Effects.Displacement.Displacement

Version: 1.1

Author: Curtis Black

Copyright: Copyright © 2008 Curtis Black

Website: http://paintdotnet.forumer.com/viewtopic.php?f=16&t=22521

Full error message: System.TypeInitializationException: The type initializer for 'CurtisBlack.Common.PDNIO' threw an exception. ---> System.TypeLoadException: Could not load type 'PaintDotNet.PdnFileTypes' from assembly 'PaintDotNet.Data, Version=4.0.5168.12074, Culture=neutral, PublicKeyToken=null'.

at CurtisBlack.Common.PDNIO.GetFileTypes()

--- End of inner exception stack trace ---

at CurtisBlack.Common.PDNIO.get_RecentFiles()

at CurtisBlack.Effects.Displacement.DisplacementConfigDialog.InitialInitToken()

at PaintDotNet.Effects.EffectConfigDialog.Constructor() in D:\src\pdn\paintdotnet\src\Effects\EffectConfigDialog.cs:line 110

at CurtisBlack.Effects.Displacement.DisplacementConfigDialog..ctor()

at CurtisBlack.Effects.Displacement.Displacement.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 913

0

Share this post


Link to post
Share on other sites

That's not my Displacement map that's Curtis black's

0

Share this post


Link to post
Share on other sites

I do apologize @TR - it is indeed Curtis's which is crashing >:O .  I got confused with all these displacement plugins!

0

Share this post


Link to post
Share on other sites

A tip for finding details about most plugins: Look at the top of the crash log

File: C:\Program Files\Paint.NET\Effects\CurtisBlack.Effects.dll

Name: CurtisBlack.Effects.Displacement.Displacement

Version: 1.1

Author: Curtis Black

Copyright: Copyright © 2008 Curtis Black

0

Share this post


Link to post
Share on other sites

Thanks @WB for explaining that :| .

 

As reported by Kelly - TR's Displacement map is crashing v4.  I will try to attach the crash log.

[hide] File: C:\Program Files\Paint.NET\Effects\CurtisBlack.Effects.dll

Name: CurtisBlack.Effects.Displacement.Displacement

Version: 1.1

Author: Curtis Black

Copyright: Copyright © 2008 Curtis Black

Website: http://paintdotnet.forumer.com/viewtopic.php?f=16&t=22521

Full error message: System.TypeInitializationException: The type initializer for 'CurtisBlack.Common.PDNIO' threw an exception. ---> System.TypeLoadException: Could not load type 'PaintDotNet.PdnFileTypes' ...

 

This will not be fixed. The plugin is using internal Paint.NET code that it shouldn't have been using.

0

Share this post


Link to post
Share on other sites

I'm still pretty sure CBM is broken. Has anyone tried it without any FileType plugins installed (does it load all the brushes)?

0

Share this post


Link to post
Share on other sites

I just tried without the Filetype plugin and it doesn't recognise any brushes; either .png or abr :( .

 

I guess you read this thread - it was problematic for some of us, but we got it sorted in the end :D .

0

Share this post


Link to post
Share on other sites

Power Stretch works for me.  I've used it a lot this past week and not one crash 

0

Share this post


Link to post
Share on other sites

Thanks Welshy. I'll update the list later today.

0

Share this post


Link to post
Share on other sites

I've updated to the 3rd beta build 5226 and found three incompatibles:

 

Hidden Content:
File: C:\Program Files\Paint.NET\Effects\EdHarvey.Effects.dll
Name: EdHarvey.Edfects.Effects.ColorFlipRotateEffect
Version: 3.5.3786.8637
Author: Ed Harvey
Copyright: Copyright © 2006-2010, Ed Harvey
Website: http://forums.getpaint.net/index.php?/topic/18811-ed-harvey-effects-v-35
Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.SystemLayer.UI' from assembly 'PaintDotNet.SystemLayer, Version=4.0.5226.41987, Culture=neutral, PublicKeyToken=null'.
at EdHarvey.UI.EtchedLine.InitForCurrentVisualStyle()
at EdHarvey.UI.EtchedLine..ctor()
at EdHarvey.Edfects.EdEffectConfigDialog3.InitializeComponent()
at EdHarvey.Edfects.EdEffectConfigDialog3..ctor()
at EdHarvey.Edfects.Effects.ColorFlipRotateEffectConfigDialog..ctor()
at EdHarvey.Edfects.Effects.ColorFlipRotateEffect.CreateConfigDialog()
at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 913

 

Hidden Content:

File: C:\Program Files\Paint.NET\Effects\EdHarvey.Effects.dll

      Name: EdHarvey.Edfects.Effects.TintEffect2

      Version: 3.5.3786.8637

      Author: Ed Harvey

      Copyright: Copyright ©  2006-2010, Ed Harvey

      Website: http://forums.getpaint.net/index.php?/topic/18811-ed-harvey-effects-v-35

      Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.SystemLayer.UI' from assembly 'PaintDotNet.SystemLayer, Version=4.0.5226.41987, Culture=neutral, PublicKeyToken=null'.

   at EdHarvey.UI.EtchedLine.InitForCurrentVisualStyle()

   at EdHarvey.UI.EtchedLine..ctor()

   at EdHarvey.Edfects.EdEffectConfigDialog3.InitializeComponent()

   at EdHarvey.Edfects.EdEffectConfigDialog3..ctor()

   at EdHarvey.Edfects.HueSatConfigDialogBase2..ctor()

   at EdHarvey.Edfects.Effects.TintEffect2ConfigDialog..ctor()

   at EdHarvey.Edfects.Effects.TintEffect2.CreateConfigDialog()

   at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 913

 

Hidden Content:

 File: C:\Program Files\Paint.NET\Effects\EdHarvey.Effects.dll

      Name: EdHarvey.Edfects.Effects.ColorFilter2Effect

      Version: 3.5.3786.8637

      Author: Ed Harvey

      Copyright: Copyright ©  2006-2010, Ed Harvey

      Website: http://forums.getpaint.net/index.php?/topic/18811-ed-harvey-effects-v-35

      Full error message: System.TypeLoadException: Could not load type 'PaintDotNet.SystemLayer.UI' from assembly 'PaintDotNet.SystemLayer, Version=4.0.5226.41987, Culture=neutral, PublicKeyToken=null'.

   at EdHarvey.UI.EtchedLine.InitForCurrentVisualStyle()

   at EdHarvey.UI.EtchedLine..ctor()

   at EdHarvey.Edfects.EdEffectConfigDialog3.InitializeComponent()

   at EdHarvey.Edfects.EdEffectConfigDialog3..ctor()

   at EdHarvey.Edfects.HueSatConfigDialogBase2..ctor()

   at EdHarvey.Edfects.Effects.ColorFilter2EffectConfigDialog..ctor()

   at EdHarvey.Edfects.Effects.ColorFilter2Effect.CreateConfigDialog()

   at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 913

 

They are now all are working after updating the plugins.  I'd assumed the v4 update would have had the latest plugins ........ so confusing all this change pcwhack.gif   sorry!

Edited by Pixey
1

Share this post


Link to post
Share on other sites

It's always a struggle to keep up to date isn't it?

I'll update this list against the 5226 build later this week.

0

Share this post


Link to post
Share on other sites
I appreciate your work always. 

 

I will report to you. 

 

My plug-in "rotate / zoom +" was fixed. (April 27, 2014) 

 

It works on PDNv4Beta(build 5226)

0

Share this post


Link to post
Share on other sites

All the plugins that didn't work because of "ThreeAmountsConfigDialog" (and 2 amounts, etc) should be working in 5226.

0

Share this post


Link to post
Share on other sites

Thanks to you both for the updates.  

 

Rick: That will shorten the list considerably!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0