Martin Osieka

'Scalable Vector Graphics' FileType Plugin (.SVG, .SVGZ)

30 posts in this topic

1) Update to the most recent version of paint.net

2) Ensure you have downloaded the .svg file correctly, and your browser hasn't injected rubbish into the file. ie: open the file in a text editor to ensure it's valid svg markup.

The fix is: change decimal symbol to <.> from <,> in Windows' Regional and Language – Additional settings...
Edited by username1
1

Share this post


Link to post
Share on other sites

Hello !

I installed the plugin correctly and I have this error :

http://image.noelshack.com/fichiers/2016/27/1467729225-fuuuu.jpg

 

I have Paint.net in English, version 4.0.9 installed,

I saw these messages :

 

 

The fix is: change decimal symbol to <.> from <,> in Windows' Regional and Language – Additional settings...

 

 

 

I'm trying to open SVG files from examples (first post of this thread) with paint.net 4.0.5 and ImSVG.Open.FileType 0.18.00 (everything is installed correctly and PDF filetype plugin from Martin Osieka works great). I'm getting this error:

System.FormatException: Input string was not in a correct format.
   at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)
   at ControlExtensions.ImSvg.Meal.EatNumber(Single& number)
   at ControlExtensions.ImSvg.AttributeOpacityInheritE(XmlNode elementNode, List`1 ancestors, String attributeName, Single defaultValue)
   at ControlExtensions.ImSvg.ElementNode(Graphics g, XmlNode elementNode, Int32 depth)
   at ControlExtensions.ImSvg.ElementG(Graphics g, XmlNode elementNode, Int32 depth)
   at ControlExtensions.ImSvg.ElementNode(Graphics g, XmlNode elementNode, Int32 depth)
   at ControlExtensions.ImSvg.ElementSvg(Graphics g, XmlNode svgElementNode, Int32 depth)
   at OptionBasedFileTypes.SvgFileType.OnLoad(Stream input)
   at PaintDotNet.FileType.Load(Stream input) in d:\src\pdn\paintdotnet\src\Data\FileType.cs:line 477
   at PaintDotNet.Functional.Func.Eval[T1,TRet](Func`2 f, T1 arg1) in d:\src\pdn\paintdotnet\src\Base\Functional\Func.cs:line 158

Please help!

But It don't works for me, the SVG file works in broswer as you can see:

http://image.noelshack.com/fichiers/2016/27/1467729402-capture.jpg

 

Thanks !

PS : Sorry for eventual mistakes, i'm not english =)

0

Share this post


Link to post
Share on other sites

Can't read the first post, link is not clickable, tried firefox, chrome and ie11.

seeing it all double

can anyone support?

thanks!

0

Share this post


Link to post
Share on other sites

That's a problem with the formatting due to the upgrade to the forum software. What's happened is that our custom TABLE tags have broken :(

 

I've put in a little fix to make the first post readable (line height increased from 0px to 1.5em - it's a CSS thing ;) )

 

Link is working as expected. Please try it again.

0

Share this post


Link to post
Share on other sites

These plugins all got broken by one of the more recent Paint.NET updates. The most optimal fix is, quite honestly, to just create a new version of the plugin.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now